Only 20 addresses show up in my counterparty wallet

Address #23 I am using as my LTB network wallet. After sending multiple assets to the address 1LA1fDA6AZDyPwXWtBZk8s2oKY3fgn4Nrq which was address #23 I reopened my counterwallet to find it missing and only 20 addresses available. When I tried to create more addresses to see if this would fix the problem I received a message that the max number of addresses allowed is 20. What happened? I did write down the private key, will swiping that address bring all the tokens with it?

I am so glad that you copied your private key, i cannot tell you how many times wallets have been lost due to this. The very first thing everyone should do in counterwallet BEFORE sending assets to them is to copy the private key.

To answer your question yes, simply sweep that private key into a new bitcoin wallet on counterwallet (a new counterwallet i would suggest) and you will see your funds go there. looking at the wallet you provided http://blockscan.com/address?q=1LA1fDA6AZDyPwXWtBZk8s2oKY3fgn4Nrq it appears as though you have enough Bitcoin in there to be able to do this so i recommend doing it right away :slight_smile:

1 Like

Why a new counterwallet? I do have several address available in the counterwallet which originally held address #23, are there any issues inherent to that counterwallet?

I wouldnt think so, but since you had more then 20 addresses created, i personally would move to a new counterwallet, but thats probably unnecessary and overkill. You should be ok using that same wallet. I have noticed that Counterwallet creates new addresses randomly for people so thats probably why you went over 20.

Just make sure you have all privagte keys saved and you should be fine

Is there an option for swiping within counterwallet? Or do I have to export a counter wallet address into another client like the blockchain wallet?

I see where to import now.

1 Like

Everything but BIPforum token came through. Not sure why.

Lets wait for the next BTC block to complete and then we can take a look at it. Right now I see that all the assets are still in your first wallet

ok. When I look at blockchain.info it shows 1LA1fDA6AZDyPwXWtBZk8s2oKY3fgn4Nrq as the sending and receiving address so I am a bit confused.

did you accidentally sweep them to the exact same address by chance?

I chose this address 1Kjj91Bh7ZWXAmeKNZ7fxekmkbmNTfyY8M from my counter wallet. I will try it again.

This time the only asset that seems to be in the process of transferring is BIPFORUM. None of the other 9 assets are being transferred.

hmm… this is very weird. Lets see what happens after this block gets completed, then maybe you should try and sweep the private key from the original address to another address that isnt 1Kjj. I am about to go eat dinner and will be back in an hour or so and I will have a better look into this.

This is a very strange thing that is going on and i am interested in helping you to resolve this. Maybe you have found some sort of bug due to the fact that you had over 20 addresses

1 Like

I tried sending to another counterparty address 14mfXiP6bY28HGH7HSRUrnjURTwhSZ6zse. This time it started with the comiccoin being transferred then it moved to the early token and after about a minute I received the message that the comiccoin was being transferred but that the “Early: funds not sent due to failure.” None of the other assets were moved either.

I tried again with the counterparty address 14mfXiP6bY28HGH7HSRUrnjURTwhSZ6zse, and again it only sent one asset, this time the EARLY token and the next token failed and none of the other assets were transferred. At least I am able to read the Early forum again. That was the one I was most concerned with.

If I’m not mistaken, this tool will ‘recover’ lost wallets: https://blockscan.com/tool_generatekey

Thanks. I haven’t lost the wallet. I have the private key to this wallet which was generated by counterwallet, the problem was that this counterwallet address is no longer visible in my counterwallet client. The other issue is when I attempt to import my assets from this counterwallet address to another counterwallet address it only does one at a time then fails. I have 7 more assets to import and it is a bit of a headache to do this one at a time.

So, the team is hashing this out right now. It’s not a bug per-se, but it’s very confusing. If you want to be able to submit (say) 10 transactions per block, you have to have 10 UTXO’s in your wallet. Send $0.20 in bitcoin from a bitcoin app (mycelium/airbitz/blockchain.info) to your Counterparty pubilc address 10 times, and thereafter you can send up to 11 transactions per block. It’s 11 in this case because we have one UTXO from your first deposit.

This is a very interesting discovery. Has it always been that way or is this thread bringing this to light?

So to clarify, are you saying that in order to move 10 assets from one counterwallet address to another in one transaction there must first be 10 UTXO’s in my wallet? Meaning 10 deposits from an non counterwallet address?