MAX button and sweep failure

My cynical suspicious mind wonders if Counterperty make this difficult on purpose so they can sweep up dust and trade other people’s coin for their own profit. I mean that’s just a random paranoid conspiracy theory and definitely not a slur.

Sweep simply doesn’t work for me, I’ve been on it for two days. I have enough coin in the receiving wallet, I use the private key and the coin I want to sweep is easily selected, that’s BTC by the way, yet it fails every time, in fact there is enough coin in both wallets to pay fees so whichever way it works I’m covering it.

Also the MAX button in send is a complete waste of time, I don’t even know why you bother having it there unless frustrating users with pointless tech is a fun game in the Counterparty office.

So the bottom line is I have several wallets with small amounts of BTC scattered here and there on the Counterparty platform and you appear to be making it very very difficult for me to gather it all in one place. I am very frustrated by the whole process, it should be a simple process because you claim to have the infrastructure in place to do the tasks but when it comes to doing it… epic fail!

I agree.

Sweep sometimes fails due to factors beyond our control (such as timeouts due to slow response of Bitcoin service).
Anyone can setup their own Bitcoin node and Counterparty server and sweep that way.
Have you tried to use CoinDaddy’s Counterwallet? It runs on faster hardware.

The unfriendly behavior of the Max button is a known issue. Counterparty isn’t a company but a community project. Some issues take longer to fix than others. Donations and pull requests are welcome.

Sweep bitcoin dust from old multisig encodings OR send all small bitcoin amounts?

If the former - I don’t know how to do it either. Please anyone let me know if you do.

If the latter - what I do is import private key to a pure bitcoin wallet, eg Electrum.

For dust, isn’t the way to do it?

See this for a workaround

I’ve given myself six months to calm down and decided to try again. Today I wanted to sweep dust from one wallet to another leaving a zero balance in the first wallet. I sent enough coin to the first wallet so there was plenty to cover fees then began the process, the system told me I was about to clear out my wallet and reduce the balance to zero so I went for it.

Process complete and I STILL have dust in the original wallet, this is maddening, I have paid out fees and not got the desired outcome. Is this a trading standards issue? Basically by paying the fees to move the coin I feel like I have purchased a service and that service has not delivered, like I’ve been conned. Financially I’m down and my problem remains unresolved.

Is there any way of destroying the wallet forever, I would happily loose the remaining dust to never have to see the wallet again?

Have you tried ?