I logged in and my address is different, and I have no balance! Help!

The FAQ link above times out and I can’t log a support issue because the json service behind the form is broken. I’ve used the correct passphrase but the wallet is empty - should be some small balances of BTC and XRT and a big chunk of privately created ‘SRTCoin’ in there. Has it been overwritten?


Maybe the counterwallet server was being updated and servers restarted, including using this forums server.
A workaround is to add a new regular address, that usually adds the “missing” address right away.

Nothing in your wallet can get overwritten - everything is stored on the Bitcoin blockchain.

This is a very concerning bug. I have created a new address, tried both web wallets, logged in, logged out, different computers. This is not cool at all.

This is my address of concern (one of them) I have bitcoin in another that is also missing. I just happened to have the public for this address because my DriveShare is running:(


I have sweeped addresses with 12 word passphrase and the public is not there in all 99 generated at https://blockscan.com/tool_generatekey? I know this is the twelve word phrase because I am using a password manager (with hardware 2FA) and have kept very meticulous record and the words do log me into an account?

This does not make any sense at all. I should have backed up my private keys within the wallet. It appears I have lost 11k+ SJCX with no logical explanation. I am sad about this fact, but even more sad that I was going to start using counterparty for many projects…I’m a little scared now that it appears I have lost the connection of the 12 word passphrase and the private key to that address:(

All private keys can be recovered from the 12 word pass phrase, so nothing can be lost, it’s explained in Counterwallet FAQs.

Counterwallet Helper script can work with an very large number of addresses (10,000 has been successfully tested) to recover all the private keys. Can you create more (say, up to 20) new addresses in your Counterwallet?
If that doesn’t help, use Counterwallet Helper to list more on your own PC.

No, I’m afraid that did not work. The valid address I had seems to have been ‘orphaned’ from the wallet credentials.

did you try with Counterwallet Helper script (up to what number)?

An address that is derived from a pass phrase is eternally linked to it, it cannot be unlinked. It’s only a matter of displaying it. Counterwallet takes just the first 20, but Counterwallet Helper can probably display all addresses linked to a pass phrase. I tried 10,000, it takes 20 minutes.
Counterwallet components were updated this week, maybe one of them changed the order of the first 20. Can you try Coindaddy’s wallet? That one is still running the previous version.

OK I will try coindaddy. Btw there was only one address previously created, then on next access using the passphrase the original balances and txion history were gone. Not sure how to run the helper, but will lookat that after trying coindaddy. Thanks, Nick

Just tried coindaddy with the same credential and it created and listed another default address. None of the other addresses were picked up. How do I run the helper?

FYI - the address I am looking for is named GAW-Telford:



  1. Install Python 2.7
  2. Copy code from here
    Is it possible to create list of addresses and private keys from Counterwallet pass phrase?
    Save it to a file such as c:\counterpartyhelper.py
  3. Use pip in Python 2.7 to install 2 modules as explained on how-to at the link above (Example 2 on that page).
  4. Run the script using Python 2.7 - how to show 100 addresses and their private keys (use your own pass phrase) is given below and is listed as Example 3 on URL above (you probably don’t have an old address so ignore example 1). If you are paranoid you can disconnect yourself from the Web or run OS from a Live CD, etc.

c:\python27\python.exe c:\CounterWalletHelper.py wallet --pass-phrase “god stock reply doctor pity ink glare air sport someone matter reach” --show-private --search-depth 100

Thanks - I’ll try that. In the meantime I note that in both the counterparty and coindaddy wallets I’m getting an uninformative error message: “Got an error when trying to sync BTC balances: error”

I just used them (to create this screenshot) and they worked fine. I think there may have been a short reorganization of the bitcoin blockchain.

Okay, so I just tried this:

  1. Create a new wallet
    Pass phrase: receive energy cream leg movie themselves ponder fruit might terror clean egg
  2. Use the pass phrase to login to wallet.counterwallet.io (running pre-release v1.7.0)
  3. Use the same pass phrase to login to Coindaddy’s wallet (running v1.6.2)
  4. Use counterwallet helper to create 5 addresses using the same pass phrase:
cd C:\Python27
python.exe c:\CounterWalletHelper.py wallet --pass-phrase "receive energy cream leg movie themselves ponder fruit might terror clean egg" --search-depth 5
address: 1G7oDB6Gb7Y5EWJzea1TyeVzE4pC2rbdaE
address: 1HmXQAns8FESSeDeb8ZMxRVwQbk1GBibRy
address: 14ah1jWFGWVmcKm2bYRkFgEEZd1PNoSPLs
address: 1PKsc1UiBAJQh9NfvnMc19YeEYu8MYpv6q
address: 1DFGShAb5KNgt16L7vn4F2rLFdBg2xUxgz

Then I kept adding new addresses in both wallets, and they appeared in the same order in the both wallets:

So in principle there’s no problem, the both versions work consistently and CounterwalletHelper works fine.

It may be possible that an address doesn’t get displayed (but we don’t know why it sometimes happen, that’s why the cause is still unknown), but CounterwalletHelper ought to be able to spit out the address as long as it’s allowed to run long enough (maybe a few hours?).

You could run CounterwalletHelper.py with --search-depth 100000 --show-private > c:\my-addresses-and-keys.txt and go see a movie (but your private keys and addresses will be output to this text file so better have control of the system which you’re using!). Then once it’s done open the file and find the address and next to it its private key.

You’re probably right. I was really hoping that CW 1.6.2, 1.7.0, and/or CounterwalletHelper would generate at least one of results in a different order…
Usually adding a new address helps, and I think in one case (if the report was truthful) someone added a handful new addresses before he was able to see the disappeared address. I haven’t heard of a case where the missing address was not listed in the first 20, though.

Well… I’m running the helper and it has found more than 200 addresses… It’s running at the moment with search depth 100000, but I’m intrigued to know where all these addresses have come from. Why so many? No sign of the address with my transactions and balances yet - waiting for the output of the big one! I’m beginning to think this wallet is corrupt?



According to the output of the helper, there are more than 10,000 addresses in my wallet! That’s not right either. And my address isn’t in there… so I guess the helper script is returning ALL addresses, not just those associated with my wallet passphrase, for some reason?

Regards, Nick

There’s more than 10,000 unique addresses that can be derived from a single pass phrase.

Counterwallet (and other wallets that worked that way) show just a subset.
The point of using Counterwallet Helper is in case that the address that someone displayed and used actually gets not shown, one can find it Counterwallet Helper and then use Counterwallet to import (weep) holdings from that address.

Any and all address/privatekey pairs can be derived from the pass phrase, so if you kept going you’d eventually get the private key for any address that can be derived from the pass phrase. But so far no one has shown that Counterwallet stopped displaying an address that actually belongs to the first 20 addresses. As far as I know there were couple of cases where the address was disassociated and had to be added by adding a regular address, but I don’t know of any confirmed case where adding up to 20 addresses didn’t help.
According to my test yesterday, Counterwallet Helper and Counterwallet 1.7.0 as well as 1.6.2 all generate and show addresses in the same order.


Many thanks …and many apologies. I get it now - sorry - I first thought the helper was querying actual addresses rather than re-generating all the possible key pairs. After some re-runs I found the missing address in the expected position in a list generated by a DIFFERENT passphrase (one character different). So there were no dissociated addresses in the first place. Just a stupid user error. Thanks for your help - at least I understand it better now! Nick

Okay, good that it’s resolved!

1 Like