Sweep Private Keys- Issue

  1. Retry to see if it works, sometimes it’s a matter of waiting longer.
  2. Maybe you have many outputs at the sweeped address and they can’t be chained. You could try importing the swept address in some other wallet (see alternative Counterparty wallets in FAQa) or a non-CP wallet and then make a send to Counterwallet (you wouldn’t need to do this if you used another Counterparty wallet since pass phrases work and wallet addresses are the same across wallets)

I accidentally sent FoldingCoins from Counterwallet to my BitCoin wallet.
Now I try the sweep them back to Counterwallet from BitCoin wallet using private key WIF.

Using Google Chrome in Counterwallet I enter the compressed WIF private key and the tokens are shown. But when I click the sweep button then only a message is shown “Preparing output for transactions chaining” and nothing happens until after some minutes it shows #error.

My Bitcoin wallet has enough bitcoins so that is not the problem.

Then I tried using the uncompressed WIF private key but then the coins are not listed to sweep.

When I first use the compressed WIF private key which shows the coins listed and then replace it by the uncompressed WIF private key then the coins are still selectable. After pressing the sweep button it shows “Step 1/5 : Sweeping 31930.214 FLDC from xxx btc adress to xxx counterwallet adress”.
But after some seconds it shows “Sweep results: FLDC: Funds not sent due to failure.”

So it is still failing. Any ideas what I do wrong?

Could it help to import my Bitcoin-QT wallet into blockchain.info online wallet and try import to counterwallet from there?

Counterwallet: 13JTuSEpKsfRUTdrHdiaMVjdQW688eiu74
Bitcoinwallet: 19dBTAZBUbCXKP8Psbc5daoFJBNsMggxD9

This is the error message in chrome console. I blacked some values if you need them I send you the full picture in private.

Is this a Cloudflare issue?
“525 SSL Handshake Failed Cloudflare could not negotiate a SSL/TLS handshake with the origin server.”

Counterwallet doesn’t use Cloudflare (the code runs on your own client (in the browser) and communicates with the API server via HTTP). Or at least it didn’t use Cloudflare until recently. @robby_dermody moved the server to a faster host few weeks ago so it could be different now, that’s something that could be checked. According to a quick check, no CDN:

Then I tried using the uncompressed WIF private key but then the coins are not listed to sweep.

Yes, because then the wallet looks at a different bitcoin address (which is probably empty). If a wallet uses uncompressed, then you need to give it uncompressed, and if compressed, then it needs compressed keys.

Could it help to import my Bitcoin-QT wallet into blockchain.info online wallet and try import to counterwallet from there?

It’s 2 steps, but it’s nicer if you can accomplish it in one (see below).

Regarding your problem, sometimes sweeps timeout because too many outputs need to be changed, other times it’s other issues. I’ve seen several different situations and in some cases it helped to retry shortly after the first timeout.

If you can, maybe it’s easiest to do this (if I got the source and destination right):

  "method": "create_send",
  "params": {"source": "19dBTAZBUbCXKP8Psbc5daoFJBNsMggxD9", "destination": "13JTuSEpKsfRUTdrHdiaMVjdQW688eiu74", "asset": "FLDC", "quantity": 31930.214},
  "jsonrpc": "2.0",
  "id": 1

Then use Bitcoin-Qt to sign and send the transaction. More here:

If you’re on Windows, using the API is a bit more tricky, but it does work:

1 Like

Looks like this is working :slight_smile:
But in the command for quantity it is in satoshi, so I had to multiply it by 100000000.
So 31930.214 FLDC = 3193021400000 satoshi

After doing this manually I tried again in Counterwallet to sweep my other coins MAGICFLDC.
This time sweep in counterwallet worked and took only 10 seconds.

1 Like

Hello! I have the same problem. foldinger, can you say what particularly worked for you? Thanks!

In Counterwallet website I could see the altcoins in bitcoin wallet and amounts using the import menu and my bitcoin private compressed wif key but could not import/sweep them successfully.

First I tried it at another day on counterparty website but it did not help.
Then I used manually the instructions from “something” for FLDC coins and the sweep was successful.
After that the counterparty website sweep worked again for another altcoin.

Manually in cmd shell:

  1. use the curl.exe command with source bitcoin adress and destination counterwallet adress, asset type your altcoin “FLDC” and quantity in satoshi, that means multiply your coin value from counterwallet with 100000000

curl.exe --user rpc:1234 -H “Content-Type: application/json; charset=UTF-8” -H “Accept:application/json, text/javascript” --data “{“method”: “create_send”, “params”: { “source”: “1234bitcoinadress5678”, “destination”: “1234counterwalletadress5678”, “asset”: “FLDC”, “quantity”: 3200000000000.0}, “jsonrpc”: “2.0”, “id”: 1 }” http://public.coindaddy.io:4000/api/

=> curl result “0100000001c…”

At bitcoin-qt console
2) signrawtransaction “0100000001c…”
=> sign result “01234…”

  1. sendrawtransaction “01234…”
    => If there was no error message the sweep was triggered successfully

Well, this is really hard for me. Do you think this bug will be fixed?

I don’t know if it will be fixed soon. But as I sucessfully did the manual instructions, I can help you make this more easy.

Do you use Linux or Windows?
Where are your coins now which you want to import to Counterwallet?
Which type of coins is it and how many?

Your help appreciated! I have them on this address 1Dn9BhNTHAPVvJwRfCgJm7i8u3pbvViMoA
I have private key for it. Amount is 1001469.3 FLDC according to counterwallet. And I have BTC on that address also to cover transaction. I use Ubuntu.

  1. Do you already have the private key in compressed WIF format? (Do not post it here!)
  2. In a linux shell is the curl command available?
  3. Is bitcoin-qt installed?
  1. No, I have private key starting with 5
  2. Yes
  3. Just installed and waiting for sync, will take some time I guess

What I can do while it is syning?

Uncompressed private keys (the ‘old’ format) start with a 5

Compressed private keys (the ‘new’ format) start with a K or an L

You need to get the compressed private key.

  1. Goto Bitcoin-qt Console and type
    dumpprivkey 1Dn9BhNTHAPVvJwRfCgJm7i8u3pbvViMoA
    => Your compressed private key starting with K or L

  2. Maybe that compressed private key even works in Counterwallet import successfully?

If not we proceed here.

As I do not have this address in bitcoin-qt I run this command:

importprivkey 5…

then I run

dumpprivkey 1…

but it shows me my imported privkey

Then use the trusted site www.bitaddress.org, ignore the % and click on Wallet Details, where you can paste your 5 private key and get your Private Key WIF Compressed. The conversion is done locally on your PC so nothing is send to www.bitaddress.org

Ok, I have privkey starting with L now. When I paste it to counterwallet it even do not show what is on address. When I paste privkey starting with 5 it showed that there are BTC and Foldingcoin and I can select what to sweep.

Last try before we do the manual steps:

  1. In Counterwallet Import, first paste the 5 key in the form, but do not press the import button
    => available coins are shown
  2. Then replace with the L key
    => available coins are not shown
  3. Click in the empty coins field and the drop down allows you to select the coins again
  4. Now try the import button

Already tried this. Here is the results:

So the manual steps:
@evolution: What is your Counterwallet public FLDC target adress?

I have a private compressed key (start with L), I see the coins in the field correctly, I have BTC for fees. in fact, there were some movements between address of the wallet that you can see 1DWcSApmoYSSQYuD2cshe3U6G1B18ZF7dB , wich allow to think that counterwallet had access to the address and the private key is correctly add… but I have the exaclty same results that evolution with FLDC (i have sjcx)

@bitcoins: In Counterwallet website import you need the 5 private key.

  1. Convert your L private key at www.bitaddress.org to a 5 private key
  2. Try again import at counterwallet website.