Sweep Private Keys- Issue


I have tried to sweep the private keys from my Blockchain.info web wallet recently and it does not seem to work.

I sent some XCP to my web wallet a while back and I can see they are there on blockscanner.

Now I have tried sweeping them onto the counterwallet in WIF, I enter the private keys into the box but nothing happens.

It does not say there is a technical error or anything it just does not react.

I have tried using several different computers and browsers but always have same issue

Anyone else have this problem or know how I can sort it out?


Does the address have some BTC on it? A tiny amount is needed to pay miners fee

Hi. Yes it does have enough btc to pay the miner’s fees.

I think I must be doing something wrong, as when I enter the private keys and press sweep nothing at all happens.

It does not go to a loading screen or anything, I press sweep and it is as if I’ve not selected anything at all.

I know the private key format must be okay as there no sign comes up saying incompatible format.

Any ideas?

Can anybody else help out ? This is really frustrating!!!

Have you tried using a different private key format? I recently tried to sweep using the WIF compressed key format (starts with a ‘K’ or ‘L’) and nothing happened, but the format which starts with ‘5’ worked fine.

Perhaps you should post the address your trying to sweep so that we can investigate why it might be failing. It might be that you don’t have enough to pay tbe BTC miner’s fee. You should also be able to SWEEP and pay the miners fees from a different address.

I have exactly the same problem as OP.

XCP confirmed at the address via Block Explorer.
Enough BTC on the source address to fund many transactions.

I paste the WIF given by Blockchain.info and nothing happens. No list of assets, nothing…

If anyone has any idea what might be the problem, that would be wonderful…
Otherwise, I guess I’ll have to use the Bitcoin-core method…

Once again, It would be helpful if people posted the actual ADDRESS that they are trying to sweep. It would allow others to investigate the address and possibly determine a cause. So far this thread has people saying they have issues, but no one is giving any additional details to try and track down the issue.

Without additional details, pretty tough to track down what the issue is.

If you have a problem with sweeping an address, please post the address here (public key only)

Dear jdogresorg,

Thank you for your answer.

1Lbh4CmorKwLPkjw2Upq3TW37hhPdEXD8q is one of the addresses I’m trying to sweep.

Thanks in advance to anyone looking into this issue, it is very much appreciated.


Indeed, it does appear that your address 1Lbh4CmorKwLPkjw2Upq3TW37hhPdEXD8q has a 0.1BTC balance… so plenty to pay any miners fee.

Can you try sweeping using counterwallet in google chrome?
1.) Open google chrome
2.) Login to counterwallet
3.) Right-click on counterwallet page and select ‘Inspect’
4.) Click the ‘Console’ tab to display any errors
5.) Try the sweep operation again
6.) Take screenshot of console and post here?

What I am trying to ascertain is if counterwallet is throwing some javascript error, or any indication of what is failing.

Here is an example of the console in google chrome.

Done following your instructions. Pasted the WIF format private key from Blockchain, and nothing happens. The Sweeping window doesn’t resize or change, no list of assets is accessible and the “sweep” button remains inactive. I tried the same with several XCP-owning addresses. Same problem in every case…

Thank you so much for looking into it :slight_smile:


I had a problems importing my compressed wif into the blockchain.info app recently, got around it by importing the uncompressed version of the pri key instead. Perhaps a soloution in this case too?

I have the same problem as you, and still doesn’t seem to work.

The last time it did work was when blockchain wallet had several other formats of private key before they updated the wallets earlier this year. I think it must be an issue with the two that they currently provide (WIF and Base 58).

Is there anyway you guys know of accessing other forms of private key on blockchain wallet? As it could be a way around it.

If anyone can think of an ulterior means of sorting it please let me know.

I’m pretty computer illiterate and use mac which makes everything I’ve heard seem pretty difficult.

If one of you would be kind enough to post a step by step instruction for MAC i would be eternally grateful!

It’s really frustrating knowing I have XCP in my bitcoin wallet, but being unable to access them when I need !!

Thanks guys,


You can try the uncompressed WIF encoding format using: https://www.bitaddress.org -> wallet details -> enter the private key from blockchain.info -> view details.

1 Like


Man… You are a godsend. Uncompress WIF works.

I love you, man ahaha :slight_smile:


1 Like

Hi all,

Using bitaddress.org did help in that I could enter the Private Keys in a way that was recognised. However now it goes to the next screen and says ‘preparing output for transactions chaining’ without progressing at all. Any other suggestions?



  1. Retry to see if it works, sometimes it’s a matter of waiting longer.
  2. Maybe you have many outputs at the sweeped address and they can’t be chained. You could try importing the swept address in some other wallet (see alternative Counterparty wallets in FAQa) or a non-CP wallet and then make a send to Counterwallet (you wouldn’t need to do this if you used another Counterparty wallet since pass phrases work and wallet addresses are the same across wallets)

I accidentally sent FoldingCoins from Counterwallet to my BitCoin wallet.
Now I try the sweep them back to Counterwallet from BitCoin wallet using private key WIF.

Using Google Chrome in Counterwallet I enter the compressed WIF private key and the tokens are shown. But when I click the sweep button then only a message is shown “Preparing output for transactions chaining” and nothing happens until after some minutes it shows #error.

My Bitcoin wallet has enough bitcoins so that is not the problem.

Then I tried using the uncompressed WIF private key but then the coins are not listed to sweep.

When I first use the compressed WIF private key which shows the coins listed and then replace it by the uncompressed WIF private key then the coins are still selectable. After pressing the sweep button it shows “Step 1/5 : Sweeping 31930.214 FLDC from xxx btc adress to xxx counterwallet adress”.
But after some seconds it shows “Sweep results: FLDC: Funds not sent due to failure.”

So it is still failing. Any ideas what I do wrong?

Could it help to import my Bitcoin-QT wallet into blockchain.info online wallet and try import to counterwallet from there?

Counterwallet: 13JTuSEpKsfRUTdrHdiaMVjdQW688eiu74
Bitcoinwallet: 19dBTAZBUbCXKP8Psbc5daoFJBNsMggxD9

This is the error message in chrome console. I blacked some values if you need them I send you the full picture in private.

Is this a Cloudflare issue?
“525 SSL Handshake Failed Cloudflare could not negotiate a SSL/TLS handshake with the origin server.”

Counterwallet doesn’t use Cloudflare (the code runs on your own client (in the browser) and communicates with the API server via HTTP). Or at least it didn’t use Cloudflare until recently. @robby_dermody moved the server to a faster host few weeks ago so it could be different now, that’s something that could be checked. According to a quick check, no CDN:

Then I tried using the uncompressed WIF private key but then the coins are not listed to sweep.

Yes, because then the wallet looks at a different bitcoin address (which is probably empty). If a wallet uses uncompressed, then you need to give it uncompressed, and if compressed, then it needs compressed keys.

Could it help to import my Bitcoin-QT wallet into blockchain.info online wallet and try import to counterwallet from there?

It’s 2 steps, but it’s nicer if you can accomplish it in one (see below).

Regarding your problem, sometimes sweeps timeout because too many outputs need to be changed, other times it’s other issues. I’ve seen several different situations and in some cases it helped to retry shortly after the first timeout.

If you can, maybe it’s easiest to do this (if I got the source and destination right):

  "method": "create_send",
  "params": {"source": "19dBTAZBUbCXKP8Psbc5daoFJBNsMggxD9", "destination": "13JTuSEpKsfRUTdrHdiaMVjdQW688eiu74", "asset": "FLDC", "quantity": 31930.214},
  "jsonrpc": "2.0",
  "id": 1

Then use Bitcoin-Qt to sign and send the transaction. More here:

If you’re on Windows, using the API is a bit more tricky, but it does work:

1 Like