Strange Indiesquare / Counterparty wallet problem

I need your help with a problem we have with a Scotcoin user who is disabled with several health issues. Scotcoin v2.0 is currently on the Counterparty protocol.

Here goes "I visited the user on the 16th of March 2018, who lives only a few minutes away from me here in Musselburgh, Scotland. He only has an iphone for his internet access. Scotcoin had an offer of free Scotcoin in a newspaper and this customer signed up for it and we sent him 1000 Scotcoin approximately 2 years ago. I got access to his iphone and he had your Indiesquare wallet installed and I finally got access to his wallet once I figured out word no.4 from the 12
word passphrase was spelt incorrectly. when logged in, all was blank. The wallet address was 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga so, I sent him 1000 Scotcoin from my Indiesquare Android mobile wallet to this wallet address which starts with 1FwjH. The 1000 Scotcoin appeared in his Indiesquare
wallet within 10 minutes and I left his house and he was a very happy man and he was not bothered that the 1000 Scotcoin he got from the historic newspaper offer was not there in his old wallet which is address 121ecwg1nvLmjbdbWGPUmcP8B3SCpCoSHj

Now, my colleague Willie Fleming (Project Director) and I heard from him last week as he wished to buy 10,000 Scotcoin from our website. My colleague Willie processed
the order and sent the 10,000 Scot to the address we knew worked on my
previous visit which was on 16.3.18 and as you will see on there
is now 11,000 scotcoin at this address.

Next, I went to the house yesterday (3rd of April) and again, I accessed the customer’s iphone and now
his Indiesquare wallet only has 1000 Scot inside with a small amount of
Bitcoin (this is the original wallet from roughly 2016 which was set up to receive
scotcoin for the Herald newspaper offer) at address 121ecwg1nvLmjbdbWGPUmcP8B3SCpCoSHj and is accessible using the very same 12 word passphrase which I used to access the other wallet address on the 16th of March. If I had not been at this gentleman’s home and witnessed this problem myself then I would not have believed it and put it down to user error (since I have worked in IT Helpdesk support since 1997). I really hope you can help. Is it possible for these two wallet addresses to be accessible using the same 12 word passphrase and how can this gentleman get access to the wallet address 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga which holds his 11,000 Scotcoin? when he signs in to Indiesquare wallet now he can only see wallet 121ecwg1nvLmjbdbWGPUmcP8B3SCpCoSHj.

To try something else I downloaded the Freewallet io app on the customer’s iphone and the same problem, the same 12 word passphrase used to access wallet 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga on 16.3.18 now opens wallet 121ecwg1nvLmjbdbWGPUmcP8B3SCpCoSHj which only has 1000 Scotcoin and a small amount of BTC. This is the same for Freewallet and Indiesquare wallet on my Android phone and the web based Counterwallet

Please take a few minutes to read and understand this problem before responding. I have already sent a similar report to Indiesquare customer support and previously contacted J-Dog who is the developer of Freewallet and also Counterparty I believe. Thank you very much in advance. I hope we can find a solution for this. Brian Mackay. IT Consultant - The Scotcoin Project CIC.

One counterwallet passphrase can have several addresses. If you have more than one address activated for the passphrase then all addresses should be shown in your counterwallet after login with your passphrase. So the problem could be you only see one address but should see two addresses in your counterwallet.

Solution: In freewallet after login with your passphrase click the action button to the top right and select “Change Address”. Then you see a list of all addresses and hopefully your missing address is shown there and you can switch to it.

(The second possibility is that your passphrase still has a typo so you really login to 2 different counterwallets with 2 different passphrases.)


Hi foldinger,

Thank you for responding to my long winded post. I have tried that in Freewallet and it shows several addresses but they all have zero balance and not the same as the one which has the customer’s 11,000 Scotcoin which is 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga

This really is one of the most mind boggling problems I have come across because the same passphrase worked on the guy’s iphone using Indiesquare wallet on the 16th of Match for this address 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga and I sent him 1000 Scot which was received ok and then I left the house. He then bought 10,000 Scot and it was sent to that same address 1FwjH.

Next visit, using the same passphrase Indiesquare, Freewallet, accesses a different wallet address 121ecwg1nvLmjbdbWGPUmcP8B3SCpCoSHj which was opened in 2016 where the customer received 1000 Scotcoin for free as part of a newspaper offer. So he is unable to access the 11,000 Scotcoin now. The only thing I did was add it as a “watch only” so he can at least see it there which gave him a small comfort.

I have also logged a question with Indiesquare support to see if they have a solution to this.

Any other suggestions would be greatly appreciated and thanks for taking the time to reply to me.

I could try changing some of the words in the passphrase because I know there is a list somewhere.

Now as you did not find your missing address in the other addresses list I’m quite sure that the passphrase has a typo and you log in to 2 different counterwallets. One passphrase opens first counterwallet with address 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga and a slightly different passphrase opens second counterwallet with address 121ecwg1nvLmjbdbWGPUmcP8B3SCpCoSHj.

Solution: There is a tool which can do the passphrase modulation to match the missing counterwallet address. It is provided by JpJa who is also member of this forum: Jpja · GitHub

  1. You need to download this zip file from his website which includes the CounterTools
  2. Extract all files from the file to a folder on your PC.
  3. In your folder open the file repairpp.html with a internet browser.
    It then looks like this:
  4. In the lower PASSPHRASE field (not the upper) you enter your passphrase and below in the ADDRESS field you enter the missing address.
  5. Click the Search button and it tries to modify your passphrase to match the address if possible

=> If it succeeds then copy the modified passphrase and if you compare with your current passphrase you should see the typo.

Thank you again for your time. I will give it a try right now.

took quite a long time but finally says “Search complete. No matching passphrase found.”

Too bad, thought that would work. Did you put in the passphrase and address right? The automatic passphrase repair can only fix one word of the passphrase. If more than one word has a typo then you can only try to fix it yourself. Or something totally different is the problem which I do not see right now.

yes, it has been copied and pasted and it has been written down. originally it was wrong when I visited the customer on 16.3.18 but I changed word 4 from sole to soul and it worked. it was a blank wallet so I sent 1000 Scot from my Indiesquare wallet and that was received on the customer’s Indiesquare app while I was still in the house. the same wallet had an extra 10,000 SCOT sent to it.

I also sent a support request on the Indiesquare FAQ page. running out of ideas. your help is appreciated very much mate

I have another idea. If we assume the passphrase is correct then the second address should appear in the same counterwallet but you could not see it. There was an issue with counterwallet where an address which was initially visible in counterwallet suddenly disappeared.

Solution: The workaround is to login the counterwallet and then go to the change address dialog which you already did. Then at the bottom there is the Options button which offers “Generate new address” when you click on it. This will generate another address additionally and with some luck also the missing 2nd address will appear again.

Hi again,

Yes, I saw that on another forum post by J-dog and tried it five times and it adds random addresses but none are the one with the 11,000 Scotcoin. How many can you add in there and once you have added a lot, can you then remove them ??? as I dont want the guy to see 10/20 different addresses when he logs into

Thanks again

In addition, I saw another post on here so I logged on to the alternative server with the 12 word phrase and the one which appears is 121ecwg1nvLmjbdbWGPUmcP8B3SCpCoSHj which only has 1000 Scot and a small amount of BTC. I added anothr 19 addresses using “create new address > create regular address” (it says I can only add 20) and none of them are the want I want which is 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga

Thanks again

I identify a couple of reasons for what you seem to be experiencing:

  • The seed phrase associated with address 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga is different from the one associated with address 121ecwg1nvLmjbdbWGPUmcP8B3SCpCoSHj
  • 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga is derived from a node path/depth that you haven’t been able to choose yet, due to wallet constraints

For the first point:
Did you independently test the seed phrase on a device the customer did not have access to and receive the same address 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga (are you sure the device isn’t compromised)?

Did you test the seed phrase using a wallet that is not indiesquare and receive the same address 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga?

Was it only on the one incident on 16.3.18 that you witnessed 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga appear?

And one other bit that is unclear: how did you discover the 4th word for the seed phrase was incorrect? And why did you send coins to the wallet derived from that seed phrase even though the wallet was blank? Why not generate a new seed? Just curious what your methodology was as it might reveal something.

For the second point:
I’m not familiar with how indiesquare does things on a technical level (which address is derived first/next, how it’s derived, etc). It is possible that the address is at a depth greater than 20. It is also possible that the node path is different altogether (e.g. unhardened), though I doubt this is the case.

FYI, I took a quick look at the CounterTools source for the recovery option and it only searches to a depth of 2 (3 addresses) – you can modify the for loop on line 120 to increase that if you think that it might be a seed phrase issue as well: (change the 3 in i < 3 to whatever depth you want + 1), just note that it will take longer to search as well.

If you’re 100%, undoubtedly sure that the same seed phrase was used to derive both 1FwjH1e2WHu3TPnkWkL23TkwNdhRtS35ga and 121ecwg1nvLmjbdbWGPUmcP8B3SCpCoSHj then I would try deriving addresses for that phrase on different node paths to a depth you’re confident wouldn’t have been reached (like 1000 or so). If you only saw that address on one wallet software, it might be worth looking into the code to see how it is deriving addresses and emulate that / see if there’s any bugs.

Many thanks for your reply ebx. I will get back to you soon. I just got back from University.