Dispenser creation stuck: generating counterparty transaction

I am trying to set up a dispenser using FreeWallet:

  1. generate a new normal btc address
  2. right-click on asset and select create dispenser
  3. I’ve completed form dispenser form as follows:

the transaction generation never completes.
If there is an alternative to creating dispensers please let me know. FreeWallet is the only way to set up a dispenser that I am aware of.


The easiest way to get around this transaction not going through, would be to make sure your “source address” is the same as your “dispenser address” in this Freewallet popup.

Make sure you are “Selected” on the dispenser address so it shows it as your source address and your dispenser address. You can do this by using the “Change Address” function in freewallet and selecting the “1HcWm…” address.

Make sure that the selected address “1HcWm” has enough BTC on the address to appropriately spend the BTC fee needed to open the dispenser. Also make sure this address “1HcWm…” has the token you would like to put on dispenser, in this case 1 unit of SARUTOBICARD.

Then by right clicking the asset in the left panel (SARUTOBICARD) or using the actions on the upper right side of Freewallet, you can set up a dispenser with the Dispenser address as your source address.

Sometimes Freewallet can get the error: “Public key was neither provided nor published in blockchain.”

Try doing a BTC send from this new address first “1HcWm”

  • basically send some BTC to “1HcWmR”

  • then send the BTC from “1HcWmr” back to another address you hold (your main address most likely).

  • Let me know if this helps.

Of course it helps! Thanks for taking the time.

I did try sending from the source rather than having a separate dispenser address. I also tried on 3 different wallets. I also tried on windows, Mac, and linux.

Finally, I tried a different network. That worked. I used a dispenser address with no btc. The source address covered the fees.

Now I’ll try to figure out why free wallet doesn’t work on one network but does on another.