Counterwallet buggy? I can't sweep SJCX no matter what! =(

Hello guys,

I’m trying (right now) to import (sweep address) some SJCX from an counterparty address at and OH MY GOD how I’m suffering with that…

So I insist: please update and solve any remaining bug that prevents counterparty tokens from being imported @ counterwallet. As I’ve whatched before, I’m not the only one having that problem while trying to sweep coins…

Ps. I even tried all other wallet options (listed here: ) but none gives me the import/sweep option…
I tried Indiesquare, Chrome Extension, Freewallet, etc…

Is development for Counterwallet still active?

edit: I’ve being trying to sweep (@ Counterwallet) since the beginning of this year (2017)… =(

Yes sweep is buggy somehow sometimes works and sometimes not no matter what.
But manually creating a raw transaction always works.

There is a website which could make it easy to create, sign and send a raw transaction. But I did not try it myself.

The manual steps I showed in this thread

a) BitCoin-Core wallet installed on your PC with your BTC address and updated to latest blockchain
b) curl command is installed

  1. Create a raw transaction with curl from your BTC public address to your counterwallet public address
  2. Sign the raw transaction using Bitoin-Core signrawtransaction
  3. Send the raw transcation using Bitoin-Core sendrawtransaction

for a) BitCoin-Core: You can use the prune=1000 in bitcoin.conf to limit disk usage to 4GB. If needed import your private bitcoin key to your local BitCoin-Core wallet first and sync to latest blockchain

for b) curl command: Download from

A raw transaction needs:
source: Your public bitcoin address
destination: Your public counterwallet address
asset: The name of your coins type
quantity: Amount in satoshi, that means value shown in Counterwallet times 100000000

In my example:
source: 19dBTAZBUbCXKP8Psbc5daoFJBNsMggxD9
destination: 13JTuSEpKsfRUTdrHdiaMVjdQW688eiu74
asset: FLDC
quantity: 25700000000

For 1) if you use Windows: Create a raw transaction in a cmd shell (all in one line)
curl.exe --user rpc:1234 -H "Content-Type: application/json; charset=UTF-8" -H "Accept:application/json, text/javascript" --data "{\"method\": \"create_send\", \"params\": { \"source\": \"19dBTAZBUbCXKP8Psbc5daoFJBNsMggxD9\", \"destination\": \"13JTuSEpKsfRUTdrHdiaMVjdQW688eiu74\", \"asset\": \"FLDC\", \"quantity\": 25700000000}, \"jsonrpc\": \"2.0\", \"id\": 1 }"

For 1) if you use linux: Create a raw transaction in a cmd shell (all in one line)
curl --user rpc:1234 -H "Content-Type: application/json; charset=UTF-8" -H "Accept:application/json, text/javascript" --data "{"method": "create_send", "params": { "source": "19dBTAZBUbCXKP8Psbc5daoFJBNsMggxD9", "destination": "13JTuSEpKsfRUTdrHdiaMVjdQW688eiu74", "asset": "FLDC", "quantity": 25700000000}, "jsonrpc": "2.0", "id": 1 }"

If successful you should get a raw transaction number like
which is needed for the next steps

For 2) In Bitcoin-Core open Debug Console
Sign raw transaction for the hex number curl result from step 1):
signrawtransaction 01000b000f4...

If successful you should get a signed raw transaction number
which is needed for the final step

For 3) In Bitcoin-Core Debug Console
Send signed raw transaction for the hex number from step 2)
sendrawtransaction 1001f3...

If successful you are done and can wait for your sweeped coins to arrive in Counterwallet!

If you have problems with the technical details of the procedure I tell you for each step what to do.

That’s gonna hurt a little…(too many GB) :confused:
…but IMO that’s also gonna be possible using

Thank you @foldinger for the detailed tutorial!

I’m gonna give it a try soon…

For BitCoin-Core you can use the setting prune=1000 in bitcoin.conf to limit disk usage to 4GB. But you still would need to download full blockchain so no internet bandwidth is saved only disk space.

If you can make it work using then give us feedback.

For 2) I get message : “complete”: true

For 3) sendrawtransaction 1001f3…

I get following Error:
64: scriptsig-not-pushonly (code -26)

Did you do it with or BitCoin-Core?

Bitcoin core
I then tried and the transactions was successfully broadcaster
Thx for help

Wow never imagined it would be such a nightmare to sweep addreses.

I am getting “{“code”: -32600, “message”: “Invalid Request”, “data”: “Invalid JSON-RPC 2.0 request format”}”

Even if I copy paste your exact command the same response. Using linux. What am I missing. I have a bitcoin node running, just this first part of generating the counterparty transaction is messing with me.

Trying to sweep SJCX. And of course, the sweep in counterwallet does not work.

There is a new method which is way more easy:

Try Jpja/Sweep-XCP-Paperwallet

1 Like

Thank god for this script. Network calls a bit buggy but allows for sweep of tokens to new address, and to Emblem Vault. Спасибо

Another approach that worked was to recreate the keys from seed at, and use that private key to transfer the tokens out.