Cannot transfer out BTC

I am trying to transfer out some BTC from my counterwallet and am receiving the following error message:

Sorry, we got an error when trying to do the requested action: ‘JSON-RPC Error: Type: Server errorCode: -32000Message: Non-hexadecimal digit found’ (API method: create_send).

If this persists, please click on the question mark button on the top right-hand corner of the screen for support options.

I’ve searched the forum and haven’t found anybody with this error message.

Actually that’s probably the most common error (JSON-RPC Error: Type: Server errorCode: -32000) on this forum.

It should be a temporary error.
Retry later or try CoindDaddy’s wallet.

Hi something, thanks for your reply
I’ve tried it four or five times over the past couple of days and I’m still getting the same error message. How long will this issue take to be resolved do you think?

I tried just now and it worked for fine me (on mainnet).

I also tried on https://counterwallet.coindaddy.io/ and I got this error while trying to login: “No counterparty servers are currently available. Please try again later. ERROR: The server is not fully caught up to the blockchain. Please logout and try later. (Most likely this message is due to the server being updated.)”

I also tried the status of my own server (no Counterwallet, just Counterparty server) and it’s working fine.

$ counterparty-client getinfo
[2016-01-06 11:41:11][INFO] Running v1.1.1 of counterparty-client.
{
    "bitcoin_block_count": 391998,
    "db_caught_up": true,
    "last_block": {
        "block_hash": "0000000000000000035310b43988568408f617bebe13e3d966dbad1b1d6a42cc",
        "block_index": 391997,
        "block_time": 1452079588,
        "difficulty": 103880340815.45589,
        "ledger_hash": "7bbf6b1db95bb454242451768fd356bab7aa709a9d5141b4e76564d7a50d2864",
        "messages_hash": "335195220e2cd6e9ff33d19743525aa108fad4bbc1511337839fc6dc1af5b568",
        "previous_block_hash": "000000000000000004f603beee2468c014f662a9ad35370fba0a7e210d6da73c",
        "txlist_hash": "b1b2b7a049c42f738864342ec5c25e4facf01e0dfb932d5f587b7a3934a1606c"
    },
    "last_message_index": 1357470,
    "running_testcoin": false,
    "running_testnet": false,
    "version_major": 9,
    "version_minor": 53,
    "version_revision": 0
}

Can you try the both wallets (Coindaddy and Counterwallet) and report which one is throwing this error?

Which two wallets do you mean?

I tried counterwallet.coindaddy.io and got the same error as you.

I don’t have the counterparty client wallet on my computer, do I have to install it to be able to run that command?

Hi Max,

I mean https://wallet.counterwallet.io/ and https://counterwallet.coindaddy.io/, they’re on different servers and use different Bitcoin Core back-end.

Client: well, the answer is “yes” you can do that easily, but, it’s resource-intensive.

  • You’d need to install Bitcoin Core with addrindex, and let it download the blockchain (few days, 100 GB of downloads)
  • You’d have to use bitcoin-cli from Bitcoin Core to “import” the private key from your Counterwallet address to your local Bitcoin Core wallet (this wouldn’t “move” Bitcoins, you’d be able to see them from any place including Countewallet - this would only make it available for use from that Bitcoin Core instance.
  • Then you’d install Python 3.4 and run pip3 install counterparty-client
  • Then you’d run counterparty-server bootstrap (30 min, about 1GB download), then counterparty-server start (30 mins, few MBs to catch up) after that counterparty-client could be used to access your wallet address (the one for which you “imported” the private key to Bitcoin Core).
  • After you’re done, you could delete wallet.dat from your Bitcoin Core, so that you don’t have to worry that someone could steal the wallet. You could import the private key again if you wanted to.

However, you asked about BTC. If you just need to access BTC from your address, you don’t need to do all this.

  • Get your private key for the address in Counterwallet from which you want to send (see this FAQ)

  • Use any Bitcoin wallet to sweep (import BTC) from your wallet. This is where you’d provide this private key. You could sweep all BTC, or just some. But make sure it’s a trusted wallet because anyone who gets the private key can take anything from the address. You could also use the standard Bitcoin Core for this, but the fastest way is to use a trusted Web-based wallet for Bitcoin.

I’ve tried both wallets and didn’t have any success. Got the same error message from counterwallet and couldn’t login to coindaddy.

I’m on xapo and coinbase web wallets and don’t see any option to sweep bitcoins from another address. There is an option in coinbase to request btc but it doesn’t ask for a private key, just the address and amount.

Hmm, that’s weird. @jdogresorg did you have any reports about wallet issues in recent days?

Many “open” wallets allow you to import private key from elsewhere. For example one of respected providers that has such a feature is blockchain.info. You can choose any such wallet - this isn’t an endorsement, etc.

Step 4 is up to you - since the same address is accessible from Counterwallet, there’s no particular reason to back up Blockchain wallet unless you want to leave some Bitcoin at the new blockchain.info address (whatever “swept” BTC you don’t send out immediately, you can send to your Xapo address). Only if you leave some BTC in this wallet does it make sense to make a backup.

Link (don’t use a demo account with real bitcoin!) to demo account where screenshot was taken and where you can “evaluate” wallet operations such as export/import, etc.:
https://blockchain.info/wallet/demo-account#

I just imported my private key from counterwallet.io wallet to my blockchain.info wallet, but the bitcoin is not showing up in my blockchain.info wallet, and I’m getting the following error message:

The Maximum Very Small Inputs Exceeded. Expected at least (40000) satoshi fee

I have not had any complaints like this in recent days. Also, it appears that the counterparty server stopped communicating with bitcoind and as a result, counterparty database fell behind for a few hours last night.

I have since restarted bitcoind and counterpartyd and all seems to be up and working normally :slightly_smiling:

Well, I think the reason is because you don’t have enough BTC (or if you attempted to manually set a low transaction fee, it was rejected) to pay for the transaction. And I think it’s the former (because you also can’t send from Counterwallet, which sets tx fee automatically to around 5500 satoshi.

See what happens with transactions which are smaller than the minimum fee:

https://server2.blockchain.info/hi/rejected

They get rejected (i.e. transactions don’t get processed by miners).
You need to pay a higher tx fee for the sweep, or you don’t have enough BTC to cover that transaction fee to begin with.

Maybe - a speculation - you sent BTC to CW with a very low tx fee and they still haven’t been confirmed enough times (I don’t even know if that’s possible). Paste your CW address (not private key) to https://blockchain.info and see what’s your balance and how many confirmations your last tx has had.

Another reference:

The balance in the CW address is here:

https://blockchain.info/address/13nd6z4dhEJrFd5ugRrTeuT6Z2JUJQY9tE

This balance is well in excess of the tx fee of 40000 satoshi.

That is freaking bizarre.
Blockchain.info uses a patched version of (old) Bitcoin Core so it’s possible it’s a Blockchain.info-specific problem. Otherwise all Bitcoin addresses can be accessed the same way, so this can’t be address-specific.

Well I guess it’s time to try another wallet.
Can you try any other wallet that allows you to import private key? Maybe Mycelium or something that looks good to you.

The mycelium wallet only runs on android from what I can see on their website:
https://mycelium.com/mycelium-wallet.html

Well I don’t know what phone you have.

Just try any other which works for you.
There was a fairly recent survey of best free wallets, you can use a stable one from that list.

I tried CW again with a small amount and got the same error message. I’ve tried another browser (chrome) and got the same error message as well.

I can’t find a wallet that permits private key importation. Coinbase and Xapo don’t permit users to import private keys. There is no function to import a private key in bitcoin core.

I downloaded multibit and found instructions here to import a private key https://multibit.org/en/help/v0.4/help_importASingleKey.html. I couldn’t follow these instructions as I am new to bitcoin and not a techie. Would you be able to simplify them as they apply to CW?

Well Coinbase and Xapo are “closed” systems.

Earlier I was on iPad so it wasn’t convenient to search for that review of open wallets that I mentioned.
I’ll post a link to updated how-to shortly.

Edit: I tried and was able to access my Counterwallet address by simply using @loon3’s XCP wallet for Chrome.
It’s a Counterparty wallet. You’d enter your Counterwallet pass phrase in this case, not the private key, and be able to access both BTC and XCP and other tokens.

So I’m stuck by the lack of a wallet that will import private keys. Do you know of any wallets that allow private key importation other than blockchain.info?

  • you could contact Blockchain.info support about the error - it is independent problem from Counterparty
  • XCP wallet extension for Chrome mentioned above works fine for me

I solved my problem by using a different address to send the bitcoin to. It must have been an issue with the address.

Thanks for your help something.