Keeps loading when trying to log in

When I enter my 12 word password, it just keeps loading? My password is correct but still I cannot access

I’m experiencing the same thing. I’ve tried regular Chrome, Chrome incognito mode and Firefox. All give the same problem indications.

This link suggests trying a different server:

Logon Problems

I was able to get to my wallet through the coindaddy server.

Both counterwallet and coindaddy are both down right now for me.

ya i tried chrome, firefox and explorer too, so annoying

Strange there is no notification from them. I hope this is not some festive attack on the platfom while everyone is AFAK. Coin daddy was working but countewallet was 100% down for the main network test net is still up and running. Then coin daddy slipped offline.

I sent tweets to them regarding it but no response. I hope they come back online soon!

me too. I can not log in from yesterday and it is loading condition. I am troubled.

You should always be able to access your XCP assets using one of the tools below. has multiple servers and if one goes down for any reason, others are available (coindaddy alternative)

Thank you for contacting me.
Try immediately.