Got an error when trying to sync BTC balances: error

For past 2 months now, im getting this error on both servers…I cannot login into the Wallet

“Got an error when trying to sync BTC balances: error”

I can access the Wallet through the BitCrystals Box … but I cannot send BTC. All the other assets I can Send Out

Whats going on?

Maybe some sort of corruption of the cached wallet file.

You’re saying you can’t log in. If you couldn’t login you probably wouldn’t see the error. Can your login or not?

Can’t send BTC: is that also for 2 months or just now? This error is due to ongoing spam attacks on the Bitcoin network and usually if you wait for 30 mins and retry it does work.

Have you tried CoinDaddy’s wallet and are you seeing the same problem?

Been trying for 2 months, both servers, get error:

Can login with the BitCrystals Box but cannot transfer BTC out of the wallet. Other assets can be transferred out of the wallet

I am getting this exact error when i am logged into google chrome. the error reads exactly as the heading of this post. I have a screenshot.

Okay, so for now, if you need the BTC you can get the private key like this (URL below) and then you can import (sweep) those BTC from any other wallet that can import/sweep (including Bitcoin Core client, if you want to download the blockchain, or a Web wallet). Please remember to leave a bit of BTC in at the address because small amounts are needed to pay for transaction fees when/if you send any Counterparty wallet out of the address (e.g. you can leave 0.01).

The second issue is how to fix this. I can’t tell what the problem might be. We’ve heard of just a handful of complaints (basically you two). I’ll check with the devs what this might be.

i guess the issue is due to other tokens or assets. I am not able to see rewards for foldingcoin or any other coins. i tried to obtain the other wallet addresses linked to my BTC / XCP address however the other wallets are just not showing up.

  • Can you try to duplicate this problem from an Incognito (Chrome) or Private Browsing (Firefox) tab or window?
    It could be that some client-side wallet cache is outdated or corrupt.

  • Do you see an error code (such as -5) when the problem happens?

How do I get the Private Key if I cannot logon to the web wallet? … also, get the same BTC error in FireFox, IE, and Chrome (Incognito Mode)

Have you tried to clear browser cache? What kind of error do you get (any error number or message)?

You can get the private key with Counterwallet Helper ( Is it possible to create list of addresses and private keys from Counterwallet pass phrase?). There are couple of pages with detailed explanations but the FAQ page should be enough.

If you’re not technically savvy you can get the same outcome from this page:
(If you wish you can open browser in incognito window and disconnect from the Internet before you run it, then close the browser after you’re done and before you reconnect. The script runs client-side and you can view the source so disconnecting and so on isn’t really necessary, but you can do that if you want).

So the “Sweep” almost worked…I see all the assets but BTC is not an option to sweep over

Here’s the error i got in IE…after I cleared all the cache:

Got an error when trying to sync BTC balances: JSON-RPC Error:
Type: Server error

Code: -32000

Message: Got call_jsonrpc_api request error: timed out

Where did you try to sweep from? A new wallet?

Yea, I created a new wallet from (…tried to do the Sweep

Okay, thanks.
Sometimes it helps to retry again after the first fail (just cancel and try again right after that, without logging out).