Getting errors when sending from BC1 address

Hi. I’m new to counterparty.

I’m receiving the following errors when I try to buy XCP with BTC from within the exchange.



failoverAPI: Call failed (across all servers). Method: get_markets_list; Last error: undefined



Error making request to UNKNOWN/Default: JSON-RPC Error:

Type: Server error

Code: -32000

Message: Bad status code returned: ‘500’. result body: '{“result”:null,“error”:{“code”:-26,“message”:“64: non-mandatory-script-verify-flag (Signature must be zero for failed CHECK(MULTI)SIG operation)”},“id”:0} '.


I was able to send BTC and XCP to my counterwallet and use these funds to create some counterparty assets, but I keep getting errors when I try to transfer ownership of an asset, or when I try to send XCP or BTC to another counterparty address.

I noticed that I have a couple of addresses in my counterwallet – some start with a ‘1’, and some start with a BC1 – the one that I’m trying to use (and that I keep getting these errors from) is the BC1 address.

Any idea what’s going on here?

1 Like

Anybody else experiencing these errors? or know if there is an issue with BC1 addresses and Counterparty functionality?

Did you try or to check if it is a server issue?

BC1 is a bech32 address using SegWit which was recently implemented in counterparty.

1 Like

This could be a multisig encoding issue for segwit addresses… Seems like the issue is that the operation is trigering a multisig encoding which is currently incompatible with segwit… will investigate

1 Like

@foldinger Thanks for your reply. Yes, I tried freewallet. The BC1 address doesn’t show up, but all of the other addresses associated with the same seed do. So no luck with freewallet. (<3 free wallet!)

I just tried — the BC1 address doesn’t show up at all.

@chiguireitor Thank you for looking into it.

1 Like

@foldinger @chiguireitor I helped Lykke fix the same or similar issue when they started using both Legacy addresses and Cash addresses. I know this is slightly different but I think it was a good catch before it got blown out of proportion like over with Lykke’s Wallet system.

Now there is one thing that jumped at me directly from the forum generated email sent to me within @fuckcomputers initial post. First off @fuckcomputers I am not talking around you so please don’t think I’m not addressing you by the manner of my reply. So back to his initial post, he said 1) he was new to Counterparty and 2) he is Buying XCP with Bitcoin. That was my initial thought until I read through his complete post. Either way buying with Bitcoin for XCP or ANY Asset is different than typical users would expect. I believe that the true issue was found and I know you will produce a solid solution like always to that issue/minor overlooked programming error. However, once the code is pushed through and that’s fixed, I would guess he may need some brief instruction on the exact channels BTCPay operates through. Or simply put, how orders are filled. So, @fuckcomputers if you need my assistance with that process, which I promise is not difficult instead it’s just Different than what I must assume you are used to. That said, I would be happy to help you out with learning about that system. Please do not hesitate to send me a direct message and I’ll answer promptly to help you get what you need.

Just remember that the extremely minor learning curve that you may require is exactly what I said, Minor. Also keep in mind it is ONLY for using Bitcoin to buy Counterparty Assets or Counterparty Assets used to buy Bitcoin. Other than that, the Counterparty DEx operates like any other Decentralized Exchange or in my heavily Biased opinion, it’s the best truly Decentralized Exchange available. So as you will most likely find with my reply’s, I generally say much more than is required and I apologize for the length of this comment. Lastly, please never hesitate to contact me to get help with anything little or large as I do not mind helping. I apologize for leaving you with that wonderful cliché for a final comment to you, however, I do mean exactly what I say.

I hope that I helped fill in what I think was overlooked by a legitimate reason. @foldinger and @chiguireitor I apologize for jumping in after you guys both commented. I just assumed that he probably ran into the typical BTCPay initial differences most users find quite immediately. So I thought I would add my 2 coins to the topic. In the end I know it will get resolved.

1 Like

Yeah, does not yet support segwit address (bc1)… that will be included in the next release which should be out shortly :slight_smile:

As far as, That server is running an older version of Counterparty/Counterwallet which does not support segwit addresses, which explains why you don’t see any bc1 addresses showing up.

1 Like

Hey @pkeane4osu – I appreciate your willingness to educate! I’m not really sure what you think I could do on my end to help resolve the issue, but I’m open to learning whatever you’re teaching! You’re obviously passionate about this stuff (:

Just wanted to let you guys also know that I just tried sending some XCP from the BC1 address within counterwallet to another BC1 address inside counterwallet and got the same error.

In summary:

  • I was able to receive bitcoin and XCP at the BC1 address inside counterwallet.

  • I was able to use the BTC and XCP inside the BC1 address to successfully create some counterparty assets.

  • I am unable to send BTC or XCP and also unable to transfer ownership of assets from the BC1 address.

  • Lastly, I’m unable to use the bitcoin or XCP inside the BC1 to make purchases in the DEX. The DEX sees the XCP and Bitcoin. But when I initiate the transaction, the error message that I mentioned in my original post, pops up.

I hope this information is useful and helps resolve the issue. I just don’t want other counterwallet users to get their bitcoin, XCP or assets stuck in a BC1 address before things get worked out. lol!

1 Like

Thanks for your reply. Excellent job on freewallet! Looks like a lot of work. Once this BC1 issue gets resolved and I’m able to dive deeper into Counterparty, I’ll pick up one of those FULLACCESS tokens from you.

1 Like

@jdogresorg you are here again, lool. hey i sent you a ticket for a couple tiny things. if you have seen it and are not doing anything you can come over to one of my servers and talk, promise it will be brief as im pushing hard to get that launched within the next day or two. so let me know.

@fuckcomputers sorry buddy i will send you a separate reply right now since the first part of this comment is located in the wrong galaxy for comments related to your post. i apologize for that.

so can i ask a question? what is the reason you are particularly set on using your bech address versus your legacy address/addresses? i appreciate the reporting of the obvious issue, however, is there a specific reason you are wanting to use bech32. im simply trying to stare into your sole and get the truth, loool, no i am just curious nothing more.

as for discussing help you would like from me ill shoot you a message here and we can discuss whatever you need my help with.

No reason at all. I didn’t know what I was doing when I created the address and used it. I’ll never use BC1 again after this! lol

i sent you the dm and to be honest why i was asking was more for @chiguireitor because if you using it for a specific purpose he would be able to iso the problem better. so thats the mistery, lool.

No need to freak out about bech addys, we will patch that up soon.


@chiguireitor Whew… Awesome. Thank you!

@chiguireitor any update on this patch?

@jdogresorg does freewallet support segwit addresses yet?

Not currently. I plan on adding that to the next release.

:+1: Good deal! Thank you.

Hi FC, having some personal/country-wide issues atm so i’ve had 2 rough months around here. When i get back to fixing the code i’ll be giving this top priority.

Hi there,

I got the same error as discussed in above topic, when sending the COVAL token form a bech 32. Has this issue been solved yet?



Error making request to UNKNOWN/Default: JSON-RPC Error:

Type: Server error

Code: -32000

Message: Bad status code returned: ‘500’. result body: '{“result”:null,“error”:{“code”:-26,“message”:“64: non-mandatory-script-verify-flag (Signature must be zero for failed CHECK(MULTI)SIG operation)”},“id”:0} '.