Counterwallet login issues?

I typed the entire 12-word passphrase with spaces, managed to get it right, but I still can’t logon to my Counterwallet. Every time I do, the loading bar is too slow or stalls completly.

You can try or use Incognito Mode on your browser on
Maybe you accessed it when the code was upgraded (to latest counterparty-lib)? (I don’t know for a fact that it was updated, but yesterday a new release of counterparty-lib came out).

I’m having what sounds like a similar issue. I’ve had a counterwallet for about a 7 months, and I wanted to login today - and haven’t been able to - different browsers, incognito, etc. - all the same - nothing.

I use either the encrypted URL or my passphrase and the “open wallet” button is never accessible.

Even tried creating multiple new wallets to test and same thing - upon creating the wallet, it drops me back on the main page and upon typing in my passphrase or URL, nothing…

have you tried possibly logging into this server

Also i know this is an obvious troubleshooting, but are you sure you have typed in your password correctly?

1 Like

Thanks folding coin, using worked. What’s the difference between these two? Originally I was a bit skeptical to do that.

This was a topic awhile ago. Here is the link to the thread that discusses this very topic and the answer can be found there within the first 5 comments [ANN] hosts public counterwallet & development servers


After transferring some BTC to my counterwallet, I got the -32000 log in error that started this thread.

Tried both quick access URL and full password, but neither got me in. Tried incognito mode, same thing.

Tried and am now back in and can see the BTC, but my other wallet addresses (which were empty, but still important) have disappeared. Any chance on getting those addresses back?


And another issue. I want to send some swarmcoin to a friend, but get this message:

Sorry, we got an error when trying to do the requested action: 'JSON-RPC Error:
Type: Server error

Code: -32000

Message: Got call_jsonrpc_api request error: timed out

’ (API method: create_send).

Looking at the Javascript, this seems to be the issue:

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience.

Any suggestions for someone who knows very little about code?

That about deprecated request might be just a warning, but not an error.

Probably it was just a transient error.
You can try some other wallet server (or retry on the same server), e.g. CoinDaddy’s CW server.

So I am a real, rank amateur. How would I switch between servers? And I tried, subsequently, to move some BTC or SWARM between wallets in my account, but got the same error. Still scratching my head…

@Andy_Tudhope, never mind, just retry, and if it doesn’t work, try

Between addresses in your wallet, I suppose.
While you can do that, you probably don’t need to do that (unless you are deliberately “consolidating” various assets on one of several addresses you have in your wallet, I guess?).

@something sorry, different wallets in my address. I am already on coindaddy, because counterwallet wouldn’t let me back in after I transferrred some BTC this morning. So many bugs guys, this is getting really frustrating… I still can’t send anything anywhere and seriously just want to take my BTC and go now… :frowning:

here’s some of the sorry story of tying to send 100 measly swarmcoin:

counterwallet-deps-min.js:405 [22/6/2015 22:6:28.129] message received: disconnect - data:undefined
counterwallet-deps-min.js:405 [22/6/2015 22:6:28.130] The client has disconnected from server:
counterwallet-deps-min.js:405 [22/6/2015 22:6:28.635] message received: reconnecting - data:1000
counterwallet-deps-min.js:405 [22/6/2015 22:6:28.732] message received: connecting - data:“websocket”
counterwallet-deps-min.js:405 [22/6/2015 22:6:29.27] message received: reconnect - data:“websocket”
counterwallet-deps-min.js:405 [22/6/2015 22:6:29.28] message received: connect - data:undefined
counterwallet-deps-min.js:405 [22/6/2015 22:6:29.28] Connected to server: Failed to load resource: the server responded with a status of 504 (Gateway Time-out)
counterwallet-min.js:13 1Fq5NELqSyGyc6wPDENuBcN7wGNBA79KyV

I can’t even see my history: “failoverAPI: Call failed (failed over across all servers). Method: get_raw_transactions; Last error: undefined”

I can understand the frustration… Can’t blame you for trying another wallet.

History can be (also) seen at (e.g.

Haha, @something I love the idea here and really want to be involved, I was just frustrated. For now, my BTC are where I feel they are more safe and movable. But I’ll stick around, cause I like you guys and half of the stuff is probably my (inexperienced) fault too :wink:

Just keep at it! I will learn code in the meanwhile and come back when I know what I’m talking about.

1 Like

andy… sorry your having issues. I just logged into and was able to login and view my addresses without any issues. Please feel free to email me at if you have any issues with the coindaddy servers :slight_smile:

@jdogresorg I really appreciate that, thanks :smile: I can see everything no problem, it’s just on sending that I get an error. Will give it a few days and see if I can send some SWARMCOIN again and will mail you if I run into the same problem.

Counterwallet is still very buggy, I would suggest using the chrome extension that i have had zero problems with

Its a great tool for just using counterparty assets, though you cannot create assets through it, using the assets works perfectly

I would say it’s not “very” buggy, it just has bugs :smile:

A lot of recent problems were caused by Bitcoin Core timeouts and they aren’t Counterwallet or even Counterparty bugs.
Today Bitcoin Core on was updated to a more recent version, although there are still at least two unresolved timeout bugs open at Bitcoin Github repo so it may not really help.
Counterparty server is dependent on Bitcoin Core so until these problems are fixed in Bitcoin Core we’ll see periodic timeouts bubble up to Counterwallet.