Counterparty testnet invalid method


I set up my own Counterparty “Federated Node” system, on Windows. I comply with all requirements Hardware / OS requirements.

I followed the guide

I have python 3.7.1, git 2.19.1, Docker version 18.03.0-ce, build 0520e24302.

My Windows is Windows 10 Home, 64 bit, 8.00 GB RAM.

I installed Docker Toolbox for Windows.

I cloned the Counterparty repository from git.

I Builded and linked the containers: fednode install base master

I have issues with the counterparty testnet, it´s running but i can´t get any response from the api.

I tested this post method from postman:
“method”: “get_running_info”,
“params”: {},
“jsonrpc”: “2.0”,
“id”: 0

The response is:
“message”: “Server error”,
“data”: “Bitcoind is running about 30943 hours behind.”,
“code”: -32000

And for an explorer ( it´s says to me after requesting the credentials : Invalid method.

Please help me to solve this issue as soon as posible.

Thanks in advance for the support and the help.

Juan Mendez

1 Like

The answer is in the question.

“data”: “Bitcoind is running about 30943 hours behind.”,

This message indicates that Bitcoind is not yet caught up. Before you can use Counterparty, Bitcoin must be caught up with the blockchain fully synced.

Wait until your Bitcoind is fully synced, and then try again.

running fednode tail bitcoin-testnet will show you the status of the testnet bitcoin sync


Thanks for your answer, Iwill wait to the Bitcoind is fully synced to continue.

I have another question, when I have the federated node fully synchronized I can use any wallet, or I should use the counterwallet instead?

Thanks in advance for the support and the help.

Juan Mendez

You can also use any of the wallets listed on at


Thank you for your answer.

I have another issue with counterparty testnet, the Bitcoind is fully synced, but the counterparty testnet its not responding.

The following is the error:

“message”: “Server error”,
“data”: “Counterparty database is behind backend.”,
“code”: -32000

Thank you so much for the help and support.

Juan Mendez

That error message indicates that counterparty is not currently caught up parsing all the blocks. You might want to try restarting your fednode and see if that fixes the issue.

fednode restart will restart all the fednode services.

You may also want to run fednode tail counterparty-testnet to watch the log file and get more details on exactly what Counterparty is doing.


I restarted the fednode and it continues with the same issue.

“data”: “Counterparty database is behind backend.”,
“message”: “Server error”,
“code”: -32000

I ran fednode tail counterparty-testnet and it shows the following:

counterparty-testnet_1 | [2018-12-03 18:18:41][INFO] Block: 386883 (0.65s, hashes: L:a3ea3 / TX:344f6 / M:be041)
counterparty-testnet_1 | [2018-12-03 18:18:42][INFO] Block: 386884 (0.61s, hashes: L:11c3d / TX:2686c / M:06a56)
counterparty-testnet_1 | [2018-12-03 18:18:42][INFO] Block: 386885 (0.62s, hashes: L:6f24c / TX:0cfc3 / M:8f8ee)
counterparty-testnet_1 | [2018-12-03 18:18:43][INFO] Block: 386886 (1.07s, hashes: L:234a2 / TX:372fb / M:18b4b)
counterparty-testnet_1 | [2018-12-03 18:18:44][INFO] Block: 386887 (0.61s, hashes: L:d20bf / TX:97e7b / M:efef3)
counterparty-testnet_1 | [2018-12-03 18:18:45][INFO] Block: 386888 (0.73s, hashes: L:7813c / TX:c9358 / M:3a83d)
counterparty-testnet_1 | [2018-12-03 18:18:46][INFO] Block: 386889 (0.71s, hashes: L:8290a / TX:7e6d0 / M:cefba)
counterparty-testnet_1 | [2018-12-03 18:18:46][INFO] Block: 386890 (0.67s, hashes: L:3fa40 / TX:0239f / M:342c9)
counterparty-testnet_1 | [2018-12-03 18:18:47][INFO] Block: 386891 (0.67s, hashes: L:f5028 / TX:7f60c / M:19f81)
counterparty-testnet_1 | [2018-12-03 18:18:48][INFO] Block: 386892 (0.60s, hashes: L:9675a / TX:7153a / M:93595)
counterparty-testnet_1 | [2018-12-03 18:18:48][INFO] Block: 386893 (0.61s, hashes: L:d86ed / TX:4ad7d / M:3f79a)
counterparty-testnet_1 | [2018-12-03 18:18:49][INFO] Block: 386894 (0.98s, hashes: L:2f0ea / TX:d5e8f / M:db1f6)
counterparty-testnet_1 | [2018-12-03 18:18:50][INFO] Block: 386895 (0.73s, hashes: L:cb992 / TX:05aad / M:ca6fa)
counterparty-testnet_1 | [2018-12-03 18:18:50][INFO] Block: 386896 (0.54s, hashes: L:5aac1 / TX:71c48 / M:4e405)
counterparty-testnet_1 | [2018-12-03 18:18:51][INFO] Block: 386897 (0.65s, hashes: L:fc41f / TX:8781e / M:c13dd)
counterparty-testnet_1 | [2018-12-03 18:18:52][INFO] Block: 386898 (0.59s, hashes: L:4dff3 / TX:f44ef / M:abc04)
counterparty-testnet_1 | [2018-12-03 18:18:52][INFO] Block: 386899 (0.65s, hashes: L:933f0 / TX:e4024 / M:eba32)
counterparty-testnet_1 | [2018-12-03 18:18:53][INFO] Block: 386900 (0.70s, hashes: L:6ced7 / TX:cc86d / M:07f2e)
counterparty-testnet_1 | [2018-12-03 18:18:54][INFO] Block: 386901 (0.76s, hashes: L:7e3f8 / TX:b06fe / M:5fda8)
counterparty-testnet_1 | [2018-12-03 18:18:55][INFO] Block: 386902 (0.78s, hashes: L:dbf3b / TX:bda34 / M:57163)

And it continues.

Thanks for the support.

Juan Mendez

It appears as if your Counterparty node is acting as it should and indicating that Counterparty is not yet caught up and ready for API queries. In order for Counterparty to accept API queries the following steps have to happen first:

  1. Bitcoin must download entire blockchain and parse it in
  2. Counterparty must parse in all transactions after Bitcoin is caught up
  3. Once all blocks are parsed, Counterparty is ready for API queries

Try running fednode tail counterparty-testnet again and it should be caught up by now. The current testnet block is 1,446,776.

counterparty-testnet_1   | [2018-12-06 16:45:12][INFO] Block: 1446771 (0.60s, hashes: L:d3e8d / TX:9da28 / M:e1ecb)
counterparty-testnet_1   | [2018-12-06 16:52:53][INFO] Block: 1446772 (0.31s, hashes: L:03107 / TX:2fdb5 / M:a5191)
counterparty-testnet_1   | [2018-12-06 17:03:32][INFO] Block: 1446773 (0.35s, hashes: L:b18f3 / TX:b7e88 / M:f714a)
counterparty-testnet_1   | [2018-12-06 17:10:55][INFO] Block: 1446774 (0.32s, hashes: L:503bd / TX:38523 / M:558f0)
counterparty-testnet_1   | [2018-12-06 17:28:58][INFO] Block: 1446775 (0.40s, hashes: L:99ba3 / TX:9642c / M:2efe9)
counterparty-testnet_1   | [2018-12-06 17:39:25][INFO] Block: 1446776 (0.46s, hashes: L:41994 / TX:d7a2a / M:122d2)

Hello dear.
I have created a post for help :blush:
I have this similar problem.
I set up my own Counterparty “Federated Node” system, on Ubuntu20.04.
As all requirements Hardware / OS requirements.
But I have got some problems.
I tried with the guide

  1. Bitcoin is syncing now from fednode tail bitcoin-testnet
    but I don’t find /root/.bitcoin/testnet3/blocks/index .
    How do I know the sync progress?

  2. I have got this result from fednode tail counterpaty-testnet.

Is right?
Someone please help on this.

See response to previous message… bitcoin and addrindexrs are probably not synced up yet, which is why counterparty is not able to connect to addrindexrs (backend)

Please read the full node installation documents at Running a Node | Counterparty