Unable to withdraw max BTC

I cannot withdraw all of my BTC from Counterwallet no matter what I try. I have more than enough BTC in the wallet to cover the transaction fee, but I always receive an insufficient funds message if I try to withdraw all of it (leaving none over). I’ve tried IndieSquare Wallet, FreeWallet, and Rarepepewallet and they all have the same issue. I’ve tried automatic fee selections and manually specifying the fee and subtracting that amount from the amount I want to send before pressing send. None of it works. How can I withdraw all of my BTC from Counterwallet?


I guess your BTC at counterwallet consists of many small btc parts. If these parts are smaller than then minimum transaction fee then this behavior can happen as each small btc part needs another transaction fee added up. If you post or send me your public counterwallet address then I can check your btc parts at https://coinb.in/#newTransaction Inputs

Workaround is to send a larger amount of btc to counterwallet like 0.001 btc which then is in one piece and then withdraw all btc with very low fee 1 sat/byte is enough currently.

Thanks for your reply foldinger! I sent some more BTC to my address and I’m still having the same issue.

I checked your address at https://coinb.in and it has
3 inputs with high btc 0.01, 0.01 and 0.055 and
3 inputs with low btc 0.0006.

I guess the 3 inputs with btc 0.0006 make the problems.
One workaround for the problem could be to use coinb.in to generate a manual transaction.

Sending a manual transaction worked! Thanks so much for your help foldinger! :slightly_smiling_face: