CW raw tx generation produces server error

Code: -32000 Message: Got call_jsonrpc_api request error: [Errno 111] Connection refused ’ (API method: create_armory_utx).

I’ve tried various browsers, clearing my cache, tried from a newly generated wallet, all with the same result. Could someone explain to me why this is happening, how I might be able to prevent such behavior in the future?

Thank you and best regards.


What’s your armory version?
I think there was a bug related to a newer version and a workaround was to use older one.

Hi Something, thank you for your swift reply. The problem is with generating the transaction in CW. I’ll have to see if other issues appear when I try to sign it but first I need a transaction to sign.

I see. Maybe armory server hasn’t been started or has stopped. Only the devs can access it so we’ll have to ask them.

I don’t know if coindaddy’s ( CW instance runs with Armory support.
@jdogresorg do you know?

Doesn’t make a difference, coindaddy CW has the same support / functionality but also results in the same error. I’ve had this issue before and after trying periodically it did start working out of the blue after a few months… but now we are back to square one, would hate to have to wait another few months :slightly_smiling:

I don’t know about Armory so I can’t tell if CounterTools can create a CP transaction the way you want ( ), but I think it would take you a minute to find out, if you don’t mind checking it out.

Looks very interesting, I’ll have to take a look at it for sure, maybe a good alternative option.

If you are familiar with debugging in browser (I use Chrome and Firefox) you can set a break point before the tx is pushed.

hextx from function sendBTCpush(hextx) is the raw tx.

CounterTools transactions are based on:

1 Like

Robby has made an update to Armory related code, maybe this will help once this gets released.