Public Passphrase & Sweepable Multisig

The address 1God8QecZZVs2jA3z5tZaAKV5gwLYtfaQv
has a publicly known passphrase: childhood confusion large many bridge guy reveal press treat soul murder crush

About 20 cent worth of BTC are stuck in redeemable multisig. Afaik there is no tool to redeem these funds. Whoever first finds a way can cash in these multisigs.

Another public passphrase is love love love love love love love love love love love love

I know 20 cent is not much of an incentive but I encourage everyone to continue playing with public passphrases. The more to redeem, the higher the incentive, the more likely someone will figure out how to redeem (and hopefully will be kind enough to open source).

This may be of interest to anyone trying to get at this dust.

address: 1God8QecZZVs2jA3z5tZaAKV5gwLYtfaQv
privkey: L5PW4My91fLmZuVLPk9nNP74ixkLdsyxQhycfnvK3CyCaomND82U

address: 1J9D6ToRRC3JHMPyCRNeCvwjAGgFt87B5C
privkey : L3mQZUVmuXXQiZ9p1w2CV3nWKGTfzZ344jtVCHFTS2hkU183A7EU

Good luck :wink:

Here’s another one: 123H4o8DFhKBBi4MEMrVFUcYebHx7MZxLx

I’ve publicized the passphrase translated to other languages. Translate it back to English to sweep it.
1-2: rot avariya
3-5: dvaele sort overveje
6-8: leise entscheiden standig
9-10: zhendui ziyou
11-12: aggrapparsi lavaggio


BC Katy, my verbose broadcast tester at, joined the party.
View instructions:

She left the 12th passphrase word hidden, but it’s relatively easy to find it programatically. Within the source code at are the functions you need. Alternatively, manually search through the 1626 combinations.

BC Katy isn’t that rich though. She has only around $1.40 in cash and about a dollar’s worth of multisig dust.

EDIT: BC Katy fell for the temptation to broadcast an image. Now her entire savings are tied up in multisigs.

Four more

  • love love love love love love love love love love love love
  • god god god god god god god god god god god god
  • heaven heaven heaven heaven heaven heaven heaven heaven heaven heaven heaven heaven
  • love god heaven love god heaven love god heaven love god heaven

Kudos to 1MXMayor for discovering these. He claimed his PIXIEDUST. Now you can grab the multisigs.


Hi, I am 1BADaNiG… and you are welcome to sweep my dust. The key shall be pretty obvious. It’s right there within my messages. It does not take a Jew to figure it out and a Mexican to do the damn sweeping job.

P.S. I luv you guys because you burned money.

so you are the guy with all the broadcasts :smiley: very interesting, can i ask why you are doing it? just for fun?

  1. I do it because I can.
  2. Boredom is a strong motivator.
  3. The Blockchain is THE GRAFFITI WALL

fair enough :smiley: I love seeing this kind of creativity though, so i encourage it. The more things we try, even a graffiti wall, will help us see everything we can do with this technology.

Are you the one putting the bible on there as well?

Some dust on 15qXHi1Pe4sLynVhF6JZJGxJX4NT6Hib1b
Key is Kx6SKBF3pBhUGLZcq3FJmHLcNZcuB4YxEdZtUcrQfzs2qdMPQx1W

I lost the pass phrase but login url is with password test.

Now it’s 2017 … one and a half years later … no one knows how to redeem multisig dust and some claim it’s impossible.

Those claims they refer to were made half a year prior to this thread, yet someone did manage to redeem these addresses. So maybe it is possible after all???

I guess the best way to find out is to donate some private keys. If you have an old, empty, unused address with multisig, please share the passphrase/public key here.

P.S. You’ll be surprised how much multisig dust there is Just this one address - 1JDogZzWJMuyeEDcuFpmLUQ2u4b6RfuDTd - has 0.33 BTC / ~$300 of redeemable dust.

1 Like

A note to potential donors: the emphasis is on unused wallets.

Do NOT share private keys from wallets which you use, or which may be used by others to send you BTC or any CP token to in the future!

1 Like

Here are two addresses with some multisig dust.

Feel free to sweep these addresses. I’ll be very impressed by whoever figures out how to do it. Would be awesome if you let us know how.

mouth crash linger black consider softly decide constantly against free cling wash

card torture treat bring invisible machine only apologize difference bold apple country

Here’s some (updated) code that I used to sweep those last two addresses last night.

It requires access to a bitcoin RPC interface with searchrawtransactions, or you can change GET_UTXOS_FROM_BITWATCH to True to get utxos from the bitwatch API and just ignore pubkeyhash txouts (which they will mistakenly list as unspent). You should configure lines 21-31 to your specific environment/need.

Note that a limit of 3000 is also used for the searchrawtransactions call, if your address has more transactions than that just increase the number for SEARCHTX_MAX_TX_COUNT.

Also, if you’d like me to send the swept funds back to you just drop me an address and I’ll be happy to oblige :slight_smile:

edit: the code itself is simple and makes some assumptions, I recommend decoding the transactions that are output before broadcasting it to ensure that it looks correct and that the fee you set is as sufficient as you thought.

edit 2: updated information because code was updated and advice relating to specific lines of code no longer made sense.

Excellent :slight_smile:

It works perfectly, just some questions / notes

  • Bitcoin RPC interface with searchrawtransactions" … this means BTC Drak’s version with addrindex?
  • I used Bitwatch api. Had to change line 133 : total += Decimal(d['amount'])
  • Need to run Bitcoin with JSON-RPC even with Bitwatch api. Setup file bitcoin.conf (lots of examples online)
  • Can do this without blockchain synced? I guess, yes you can, but I have it synced so didn’t try
  • I check the address on prior to running the script
  • I set fee at 0.0002 per kB (2 mBTC, around 20 cents)
  • Put Bitwatch’s suggested fee as fee parameter in the script
  • Remember that 100,000 satoshi = 1 mBTC ~= 1 USD
  • The fee eats up a 1/4 or so of the sweep amount
  • The final signed transaction I copy and verify/broadcast at
  • Some block explorers display the unconfirmed transaction, others don’t
  • Keep the tab with the unconfrimed tx open and hopefully in a day (or a week) you’ll see it confirmed

Yes, exactly.

Nice catch – I added that line quickly before I posted as a nicety and didn’t check it with the bitwatch API. I’ll update the gist in a bit.

This is true as it uses the RPC interface to create/sign/broadcast the transactions as well, sorry I should have mentioned that. I believe you’re correct that it would work without being synced, but I am not 100% sure on that without asking about it myself or looking at the code.

I noticed similar behavior only I didn’t use bitwatch to calculate the fee (I think I’d actually recommend against using them for this unless you know which transactions listed are valid so that you can manually remove them since they list spent transactions as unspent) – the transactions are going to be larger because it is combining many inputs and thus require a decent fee to process quickly (especially with the current state of things).

On the last sweep that I did ( the tx size came out to over 5KB and I paid 0.00058466 in fees to transfer 0.00253834, hefty but still profitable. Some experimenting could be done here with minimal fees and using RBF to replace until confirmed (like Peter Todd does with OpenTimestamps) – if you want your transaction confirmed relatively quickly, the trick is to pay at least 10k sats/KB (which it seems like you did) and then get lucky submitting it to :wink:

I’m not sure what’s up with the many explorers not displaying or accounting for the transactions. Blockscan (before it went down) still listed the multisig balance and bitwatch doesn’t actually seem to parse for unspent transactions again until well after a send has happened, which will lead to successive calls failing if not all of the utxos are swept in one go.

Hi users,

im having this issue with one of my wallet which i had used for mining bitcoins. i was receiving bitcoins from genesis mining into this blockchain wallet.
left the wallet alone till recently when i decided to sell some of the bitcoins, i noticed that i am unable to transfer all my bitcoins. There is a message asking me to consolidate unspent outputs.
so, i checked with blockchain wallet and they told me to send tiny transactions to another wallet. Long story short, i tried it, no improvement to the spendable balance. only further reduced my balances actually.

Then i found out about through this thread. So, i tried it out. bear with me, I do not have much knowledge about programming or stuff, im doing this by learning from the forums and so on.

first thing, i got a hex string from the bottom of the bitcoin sweeper tool, tried to verify it at but it shows me “Unable to decode”.

so, after checking a few times i noticed that, for the “hash” which is listed in the bitcoin sweeper, i noticed that if i include only the ones which has “Vout” value of 0,1, and 2, it doesnt turns out error and successfully decodes. when i include those with “vout” of other values then, the hex string is unable to be decoded in the attached a screenshot from bitcoin sweeper page

i am at this point clueless as to what else i can do to regain all the btc in my wallet

i am posting this up, in the hope of getting some expert help from all expert members here. i believe this can also be helpful for a lot of blockchain wallet users who are still looking for a solutioon to this issue.
looking at the current bitcoin prices, i realised i will have to gain control of all my btc at this time. hope to get some helpful feedback from any members of this forum.

hi @JPJA @ebx,

looks like you both have found the solution and know wxactly what to do. very nice but, the issue with me is that i do not understand the language you guys are speaking. haha. Please, will be great if you can assist me in this.

thank you

Hey @joelb88!

So, there are a good chunk of UTXOs that come from large transactions, e.g. look at the outpoint here – 3b791d360556423db6ba749899764b3276318cc3403c45a6ff4fc2e9e70862da:188

This is part of a transaction that is 50KB+. I was originally guessing that was choking on decoding the large transactions, but that turned out to not be true. The real issue I think was that you were trying to make the transaction with a lot (if not all) of your UTXOs in one go, my script calculated you have:

2017/11/08 14:52:42 sweep_funds  INFO     Found 395 UTXOs on 1C5r7QJaQznPVxMCyBouWLCKDGPQ9dLiWN with a value of 7.82991871

That’s quite a lot of inputs to add to a single transaction (I calculated the transaction size would be roughly ~16KB unsigned) and, I’m guessing (and only guessing) that was choking on this fact. Just as a test, I tried making a transaction with 15 of the larger inputs to see if could decode it and it could:

2017/11/08 15:01:14 sweep_funds  INFO     Fetching transactions for 1C5r7QJaQznPVxMCyBouWLCKDGPQ9dLiWN .. this might take a while ...
2017/11/08 15:03:26 sweep_funds  INFO     Found 857 transactions
2017/11/08 15:03:32 sweep_funds  INFO     Found 395 UTXOs on 1C5r7QJaQznPVxMCyBouWLCKDGPQ9dLiWN with a value of 7.82991871
a4aaf3f186fe43012ec0a90ba56858206f92fb792052add46c863614c2c01da5:1141 -- 0.00126384
e0170b59c6a3c96b87841d89cbaa92c9f7bccbea7dd1893b45779a2d75358c55:1137 -- 0.00124916
ce614c01e2104f30c1ae27d896f6d2d0c5816a185a0759d71cd89f4abe4282ac:1138 -- 0.00122743
9410aeaf9855f62216a7c1056fb04c7b80ce0dd8d4208b335d538ed254b48d5c:1139 -- 0.00121117
a97cd0612c46033400def6a4a265c2f1897471efa2ef83584be7e2a57a641751:1133 -- 0.00119059
0bd524cafc6c5e1effbd0ba1497fbb0b380a3bdb622677e5261c4c6106a1a805:1131 -- 0.00114806
6c353202421ac7d4e91c4126b9ec3adc3ffee9b8bcac1dc70a121e07a6640168:1134 -- 0.00113921
020ce6e094a2933b1dd0569c756f546fef374b9fc797682b0261b024bd1db01b:1136 -- 0.00112942
7c8a7315eb5026dcd71e1e84166f119bb9339fab3cc4b8ac9cc5d2628154ddca:1143 -- 0.00111632
a78f7da21c9c0050c8f70bcd4e4e921ce9508b66456e8055725d40ab9d975c6b:1139 -- 0.00111049
b20bc545a34d70b20615ef2e9cb08a137e2080c520b4a6181d6c4878915af1c5:1135 -- 0.00110894
a1d4bd8fda17b8f2904191983b537ea5989b1560941d32686d40119e0b87c5b8:1141 -- 0.00109523
1ca317958e37580f75bf3c92f7f23d452e4b9a47c4f19713b9034c9048e39572:1128 -- 0.0010461
d9b25116a8310079148477e5d169a94ab4909017ea7b2c98e5c3fe3f152665f0:1286 -- 0.00060026
86b34ec55cfc5eaa23acfb8503fe974b4e58423eafe0e2e3bf4ba67eb5f770bd:1204 -- 0.0002581
2017/11/08 15:03:32 sweep_funds  INFO     
Unsigned TX: 010000000ff06526153ffec3e5982c7bea179090b44aa969d1e5778414790031a81651b2d90605000000ffffffffbd70f7b57ea64bbfe3e2e0af3e42584e4b97fe0385fbac23aa5efc5cc54eb386b404000000ffffffffcadd548162d2c59cacb8c43cab9f33b99b116f16841e1ed7dc2650eb15738a7c7704000000ffffffffb8c5870b9e11406d68321d9460159b98a57e533b98914190f2b817da8fbdd4a17504000000ffffffffa51dc0c21436866cd4ad522079fb926f205868a50ba9c02e0143fe86f1f3aaa47504000000ffffffff6b5c979dab405d7255806e45668b50e91c924e4ecd0bf7c850009c1ca27d8fa77304000000ffffffff5c8db454d28e535d338b20d4d80dce807b4cb06f05c1a71622f65598afae10947304000000ffffffffac8242be4a9fd81cd759075a186a81c5d0d2f696d827aec1304f10e2014c61ce7204000000ffffffff558c35752d9a77453b89d17deacbbcf7c992aacb891d84876bc9a3c6590b17e07104000000ffffffff1bb01dbd24b061022b6897c79f4b37ef6f546f759c56d01d3b93a294e0e60c027004000000ffffffffc5f15a9178486c1d18a6b420c580207e138ab09c2eef1506b2704da345c50bb26f04000000ffffffff680164a6071e120ac71dacbcb8e9fe3fdc3aecb926411ce9d4c71a420232356c6e04000000ffffffff5117647aa5e2e74b5883efa2ef717489f1c265a2a4f6de003403462c61d07ca96d04000000ffffffff05a8a106614c1c26e5772662db3b0a380bbb7f49a10bbdff1e5e6cfcca24d50b6b04000000ffffffff7295e348904c03b91397f1c4479a4b2e453df2f7923cbf750f58378e9517a31c6804000000ffffffff0136bd1700000000001976a91479940af160bdf558ff2906b8ff9a37669a717fe288ac00000000

The above transaction uses those 15 UTXOs and spends it back to 1C5r7QJaQznPVxMCyBouWLCKDGPQ9dLiWN to create a ~2.2KB (when signed) tx with a 0.00033666 BTC miner fee-- note that you could sign this transaction and broadcast it, but you’d obviously be trusting me that the transaction does what I said it does (unless you decode it yourself with bitcoind or something like

If you can expand on what it is you want to do and what your limitations are I could modify my script with some optional arguments to support your needs, some other people have had similar issues creating transactions with a large amount of UTXOs on the address with the script. Do you have a bitcoin core node? redeem.bitwatch can sometimes return spent outputs as unspent (edit: actually, this was probably the cause of your issue. I see that your address has some unconfirmed transactions and I know from past experiences that it takes a while for bitwatch to account for those).

What wallet are you using that won’t even let you create a transaction with some of your UTXOs until you consolidate it so that it’s fewer? If that is the only issue, and you just need to consolidate the many inputs into a fewer amount I suppose it wouldn’t be too bad to just create a few ~5-10KB transactions (reasonable enough, maybe could be larger). I could add some options that allow you to specify the amount of inputs to use for a transaction, or I suppose better yet would be able to specify a custom transaction (rough) size.

Also, I’m not sure why you’re using to sign transactions but Bitcoin Core will happily sign even very large transactions without issue if you wanted to make one big transaction to consolidate all of the inputs at once, assuming that size would be < 100KB.

Hi @ebx,

great to hear from you…

yes i was trying to make the transaction with most of the UTXOs in one go. so, i should break it down to smaller number for each transactions. probably 20-30 transactions each time rather than all 395 transactions at once. thats 1 pointer for me…

Great, thanks for the TX id, i can verify, sign it and then broadcast it but, my concern is if it will affect the larger balance in my wallet. will it negatively impact the other untouched unspent outputs? should be no i guess.

I am using a blockchain wallet. as you already know, theres a huge balance of btc in my wallet but i can only spend 0.02 btc after minussing all my fees. thats crazy right. so i will have to consolidate all my unspent outputs so that my transaction fees can be reduced and i can spend the total btc i have in my wallet. i do not want to sacrifice 99% of my balance just to transfer it. that will be the disaster… haha

i was intially using redeem bitwatch and as i was new to this. i just downloaded bitcoin core and am currently syncing it. should get it synced probably by the next 24 hours. Yes i noticed that redeem bitwatch sometimes returns the spent outputs as spent. i think the developer has abandoned this program. tried reaching the person but, no response. that is why i am thinking of using your “sweepfunds” program, and i got the bitcoin core started.

yea, since i am getting the bitcoin core synced now, i can use it to try this out but, as i mentioned i am still a baby at these things. still learning as i go. Looking back at the previous discussions in this thread, the furthest i could go is RPC console but, i have lots of questions on how to use it. The program that you wrote “”, do i run it on the rpc console or on phyton?
and another thing, how do i get the addrindex patch to my bitcoin core…?

Thanks for the assistance @ebx. hear from you soon