Install problem

Hi everyone, I am trying to install counterpartyd.

Ubuntu 12.04 64 bit
bitcoind up and running

I am following the install instructions in:

sudo apt-get -y update
sudo apt-get -y install git-core python3
git clone ~/counterpartyd_build
cd ~/counterpartyd_build

OK so far

sudo python3 --with-bootstrap-db



2014-09-26 07:58:46,560|DEBUG: base path: '/root/counterpartyd_build’
2014-09-26 07:58:46,560|DEBUG: dist path: '/root/counterpartyd_build/dist’
2014-09-26 07:58:46,560|DEBUG: env path: '/root/counterpartyd_build/env’
2014-09-26 07:58:46,560|DEBUG: bin path: '/root/counterpartyd_build/bin’
2014-09-26 07:58:46,560|INFO: Installing Counterparty from source for user ‘root’…
/bin/sh: 1: cd: can’t cd to /root/counterpartyd_build/dist/counterpartyd
Traceback (most recent call last):
  File “/root/counterpartyd_build/”, line 99, in git_repo_clone
    % repo_dest_dir, shell=True).strip().decode(‘utf-8’)
  File “/usr/lib/python3.2/”, line 522, in check_output
    raise CalledProcessError(retcode, cmd, output=output)
subprocess.CalledProcessError: Command ‘cd /root/counterpartyd_build/dist/counterpartyd && git rev-parse --abbrev-ref HEAD’ returned non-zero exit status 2

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File “”, line 468, in
  File “”, line 459, in main
    checkout(branch, paths, run_as_user, with_counterblockd, command == “update”)
  File “”, line 123, in checkout
    os.path.join(paths[‘dist_path’], “counterpartyd”), branch=branch, for_user=run_as_user)   
  File “/root/counterpartyd_build/”, line 101, in git_repo_clone
    raise Exception(“Cannot get current get branch for %s.” % repo_name)
Exception: Cannot get current get branch for counterpartyd.


The directory /root/counterpartyd_build/dist/counterpartyd doesn’t exist, should I go ahead and create it by hand?

Any other hints?

That’s what I would do. Did it work? It’s been a month or so since I ran the installer but recall having to do something like that when I set it up.

Yes, it worked. Installing now. I will write again to report successful installation and test (or other installation problems).

Error (curl not installed)

Installed curl


2014-09-26 09:53:58,074|DEBUG: RUNNING COMMAND: ln -sf /usr/bin/python3.3 /usr/bin/python3
2014-09-26 09:53:58,077|DEBUG: RUNNING COMMAND: rm -f /tmp/; curl -o /tmp/
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:–:--  0:01:03 --:–:--     0curl: (7) couldn’t connect to host
2014-09-26 09:55:01,213|ERROR: Command failed: 'rm -f /tmp/; curl -o /tmp/

Any hint?

Well that site is indeed down so perhaps you must wait.

The only other thing I did when working with this was to checkout the develop branch for counterpartyd_build.

git checkout develop

Thanks for the common sense weex, it’s down indeed! I didn’t even think to check. Will try again later after checking if the site is on.

thanks for the heads up…should be fixed, please update the script from git and try again

Thanks xnova. Done that (still had to create the directory counterpartyd in dist manually). But there is an error:

2014-09-27 13:13:13,814|INFO: Creating virtualenv at ‘/root/counterpartyd_build/env’ …
13:13:13,815|DEBUG: RUNNING COMMAND: /usr/local/bin/virtualenv-3.3
–system-site-packages --python=python3.3 /root/counterpartyd_build/env
Running virtualenv with interpreter /usr/bin/python3.3
Using base prefix '/usr’
New python executable in /root/counterpartyd_build/env/bin/python3.3
Also creating executable in /root/counterpartyd_build/env/bin/python
Installing setuptools, pip…done.
/root/counterpartyd_build/env/bin/pip install -r
not open requirements file: [Errno 2] No such file or directory:
Storing debug log for failure in /root/.pip/pip.log
13:13:20,261|ERROR: Command failed:
'/root/counterpartyd_build/env/bin/pip install -r

I will look into this later and see if there is something simple that can be done.

hmm…this is under ubuntu 12.04? try 14.04 … 

can fix 12.04, but it won’t be for awhile …just don’t have the time…unless someone can submit a pull request

@giulio the files obviously aren’t there, which means you need to re-wget them or get them manually from Github. Delete the directory and run the procedure again (or get those files manually from Github).

If it still doesn’t work then it’s most likely related to this being 12.04. As xnova said you’d better switch to 14.04 (you can upgrade online but it’s faster to install a new one from ISO if you have a VM).

And to also comment to your original post:

/bin/sh: 1: cd: can’t cd to /root/counterpartyd_build/dist/counterpartyd

The install document clearly says (it’s even bolded):
"As the user you want to run counterpartyd as, launch a terminal window, and type the following:"
But you’re running as “root” user. If you want to run as root, that’s okay, but you’re introducing additional variables to the equation. 

@something re "the files obviously aren’t there, which means you need to re-wget them"

That’s what I did. Will try again or get them manually.

Okay, also please use a user account such as “xcp” or anything else but “root”.

Hi there
Over 6 month out of the scene, 'need to relearn, reinstall & update stuff.

sudo apt-get -y update
sudo apt-get -y install git-core python3
git clone ~/counterpartyd_build
cd ~/counterpartyd_build

Here I rename /panonym/counterpartyd_build/dist/linux into counterpartyd (got same result by creating an empty folder of that name).
I checked that contain the modif done by xnova.

sudo python3 --with-bootstrap-db

Things seem to finally go smoothly, until:

Could not open requirements file: [Errno 2] No such file or directory: '/home/panonym/counterpartyd_build/dist/counterpartyd/pip-requirements.txt’
Storing debug log for failure in /home/panonym/.pip/pip.log

2014-10-07 18:49:52,744|ERROR: Command failed: '/home/panonym/counterpartyd_build/env/bin/pip install -r /home/panonym/counterpartyd_build/dist/counterpartyd/pip-requirements.txt’

I tried creating this
pip-requirements.txt with blabla, the red error just become way longer.
Here is pip.log

Any help appreciated.