Cannot Redeem Mulitisig Dust

I’m using this tool:

Problem 1: Counterwallet will only sign the transaction if I include very few unspent outputs, like 3-4 max.

Problem 2: Broadcasting the signed transaction works only if just one unspent output is included.

Haven’t tried to do this myself. Looks like a bug.
Have you tried to do the same from the CLI (and without using that Web site), to be able to tell if it’s the site or CP s/w issue?

I don’t have the CLI installed but I tried other tools can sign a hex string from If it contains dozens of inputs, doesn’t matter, it successfully signs (beware: you need to insert your private key - i only dared to use a test account).

Then I tried to push the signed tx from,, and Neither of them worked.

Then I tried once more, but only with one input this time. Again, the signed tx from could not be pushed. In Counterwallet I could sign and push it successfully.

The signed hex looked slightly different in Counterwallet and but I could not copy it from CW’s GUI, hence not test if it could be pushed from one of the above mentioned sites.

If you feel there’s a bug in CP feel free to submit it on Github.

OT: if you install Virtual Box with a minimal Ubuntu 14.04 instance you can install counterparty-client and configure it to use public servers (for both Bitcoin Core and counterparty). I can’t remember if there are any public Counterparty testnet servers, though.


  1. you can also install counterparty-gui at the same time, if you want to be able to use a GUI for simple operations (Send, basically, although on Ubuntu (and Linux in general) there are too many Python dependencies that need to be installed so I wouldn’t recommend this for Linux - only OS X and Windows)
  2. You can also install counterparty-client (and GUI) on Windows without any VM’s, and use it from Windows shell. This is quick and easy, but the Windows shell is a nightmare.

I also tried this dust sweep using redeemm.bitwatch several times to no avail. So, I’m in a holding pattern, waiting for things to mature.

However, I did see this here…