MAX amount -> Insufficient BTC at address

Sending maximum amount of btc from Counterwallet still broken. When it’s planned to be fix? If i sending XCP with MAX button it works perfectly, but if i trying to send BTC then i’m getting annoying: Insufficient BTC at address 176ZXsA526eRZuxMMCC4wEpZdJjadjvbdR. (Need approximately 0.57436818 BTC.). You must have a small amount of BTC in this address to pay the Bitcoin miner fees. Please fund this address and try again.

Could be candidate for a bounty.
@jdogresorg are you aware of this problem?

Yes. I believe it is related to the fee calculation in counterwallet.

Feel free to take a crack at it if you want :slight_smile:

I also replied to this post on bitcointalk.

As to the bounty question, I think we should round up all the top counterwallet issues/updates that we the community wants and put a bounty on all the updates. In the meantime, i’ll try to figure out this max BTC issue.

In the meantime you can get the privkey and send the max amount of BTC from another wallet (Indiesquare Wallet, for example) or

A list of Counterparty-compatible wallets -

Should i hope that the problem will be solved or simply move on to another bitcoin client?

It won’t be solved quickly as in within a week. It may be solved this month, but first someone needs to debug it and then fix it, plus some testing period.

Last weekend I used RarePepeWallet with my Counterwallet pass phrase, and I was able to send BTC from it (it uses a different approach to compose transactions). The reason for Counterwallet having issues with the address may be that it had many unspent outputs (> 100).
I see your address has 16 ( so that may be why. 16 isn’t huge, but it may be why.

Too bad it (RarePepeWallet) is not available for testnet, because I have a testnet address that is having this “insufficient BTC” problem and could be used for troubleshooting.

Apart from RarePepeWallet, Indiesquare can be used as well (works with Counterwallet pass phrase) and you can also try CounterTools or even (if you want to send BTC) Bitcoin Core (import private key, but you’ll have to do a rescan of the entire blockchain which may take whole day on non-SSD disk, assuming you have a copy to begin with).

This weekend I’ll troubleshoot that testnet address to see if I can find more about this problem.

If you could report which one worked for you, that’d be nice.

I’ve imported addresses directly to Electrum. It sweeps clean the addresses next time you send. It works if you only have BTC, not XCP or assets.

Note that you need to import each address individually with private key, not passphrase.
Also note; recently I tried newest version of Electrum and I didn’t find this option, so you may try an older version

1 Like