Can't log in- [Errno 24] Too many open files

I’ve never had a problem with counterparty til today.  I tried to log in with the 12-word passphrase, and it said I’m logged in somewhere else. I only use this computer for counterparty, so I shut it down & restarted.  still got the error.  does this mean someone else has my passphrase??

here’s the full text of the error msg:

Got an error when trying to sync BTC balances: JSON-RPC Error:

Type: Server error

Code: -32000

Message: Got get_url request error: [Errno 24] Too many open files

No, most likely the server you were on was experiencing some slowness. There are multiple servers so logging out and logging back in may help.

I can’t log out, since I’m not logged in to begin with.  I just tried it again & got the same thing.  is it just a heavy server load?  I’ll try it again tomorrow.

@shawn_j, it’s probably a bug that’s been hard to exterminate because it’s intermittent and requires near-real-time server-side debugging.

If you’re not logged in twice, it’s OK to click Continue. 
More info:

I can do nothing, all the suggested solutions failed. Can’t log into my wallet. This bug should be fixed ASAP!!

Surprised by this. I’ve got the same error message and I’ve not been logged in for weeks.

Error I got was at login rather than any BTC sync:

No counterparty servers are currently available. Please try again later. ERROR: JSON-RPC Error:
Type: Server error
Code: -32000
Message: Got get_url request error: [Errno 24] Too many open files

So, I tried again … and again a few times and then did get in. Perhaps the server does have too many accounts open?.. I hope it’s not being spammed in some way and rather that it’s just down to too many new users. Market seems to be doing well at the moment, so hopefully CounterParty is starting to get the attention it deserves :slight_smile:

Also experiencing this. Per @something 's suggestion that it may require real-time server side troubleshooting, it may be good to say if you are willing to connect to be the user on the end of that troubleshooting session.

There was a fix (or at least an attempt to fix) this - I believe the system setting for “the max number of open files” was increased. We’ll see if that’ll fix it.

I’m also having trouble logging in. The message says

fallover API:call failed(failed over across all servers)
Method:got_normalized_balances;last error:JSON-RPC Error:

Tyep: Invalid params

I made sure my passphrase was correct and also I am able to log into my other counterwallet account. So it seems like it is the issue of this particular account. The problem started yesterday and I tried again just now but it’s still not working.

Please help. Thanks!

It could be (did you open that it’s some sort of database corruption on the CW servers in which case a reparse would be required. However it probably won’t happen before Monday morning US time (at earliest).

Have you tried

Thnaks for the link. I think I’m having the same exact problem with Nexxus Drako. 

So the best course of action is basically wait till Monday morning(earliest) right?

It kind of sucks for me but thanks for the info! 

It’s been fixed already I think (see the Github link)